Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Richard Walters 48 karma points
    Jul 27, 2010 @ 13:31
    Richard Walters
    0

    4.5.1 not installing properly

    Hello,

    I'm trying to install Umbraco 4.5.1 on a shared hosting server (SoftSys) on which I already have a few installations of Umbraco 4.0.x running.

    From the very beginning of the installation process, it seems that something is wrong (maybe missing CSS), as the usually well-formatted installation screens are bunched together in the top left corner… some buttons are even 'covered' by other elements and must be tabbed to in order to be selected.

    Once the installation is complete, the "no pages found" page also looks a little off… but the worst problem is that almost all of the back-end interface is missing!! (I've attached a screenshot below.)

    Has anyone else encountered this and found a resolution? If not, any suggestions as to what I might be looking for? I'm at the end of my rope (and resources) on this one…

    Thank you,
    Rick Walters

  • Seth Niemuth396 karma points
    Jul 27, 2010 @ 14:46
    Seth Niemuth
    0

    You should make sure that everything unzipped alright as people have had problems with windows blocking some files from actually unzipping:

    http://our.umbraco.org/forum/getting-started/installing-umbraco/10808-Clean-Install-of-45-and-no-trees-tried-other-solutions-but-still-not-working!

  • Seth Niemuth396 karma points
    Jul 27, 2010 @ 14:46
  • Michael Lawrence198 karma points
    Jul 28, 2010 @ 05:13
    Michael Lawrence
    0

    I'm using SoftSys as my host as well and it installed just fine. Now all of a sudden I'm now experiencing the same exact issue as you. I use 7-zip for my unzipping and I followed the upgrade guide. None of this has helped.  I did notice that when I navigate to the DependencyHandler.axd path that the page is requesting for it's css is gives me a 404 error. Possibly something is going screwy with the DependencyHandler.axd ?

     

  • Paul Blair730 karma points
    Jul 28, 2010 @ 07:10
    Paul Blair
    0

    The reason this is happening on SofySys is you have to comment out the  <system.web.extensions> section in your web.config.

    Also, for 4.5.1 projects @ SoftSys I have had to explicitly put <trust level="High" /> into my web.config. My rpevious projects had always been in high trust mode automatically so this may be something to do with the change to .NET 4.0

  • Michael Lawrence198 karma points
    Jul 28, 2010 @ 07:21
    Michael Lawrence
    0

    I just tried your recommendations and it didn't seem to affect anything.  I'm still getting the same CSS/Javascriptless backend. :(

  • Michael Lawrence198 karma points
    Jul 28, 2010 @ 07:26
    Michael Lawrence
    1

    I think I figured out my problem. I changed it from ASP.NET 4.0 (Integrated Pipeline) to just ASP.NET 4.0 under the website's Extensions tab and that seemed to do the trick.  Try it out and see if that fixes your issues too!

  • Paul Blair730 karma points
    Jul 28, 2010 @ 09:19
    Paul Blair
    0

    I am using .NET 4 integrated pipelines mode OK on SoftSys. Maybe it's worth raising a support call with them if it doesn't work for you - they are very responsive.

  • Richard Walters48 karma points
    Jul 28, 2010 @ 13:48
    Richard Walters
    0

    Thank you all for the helpful replies.

    Turning Integrated Pipeline off as suggested by Michael did the trick instantly.

    Interestingly enough, I'm also doing a pre-upgrade test install of 4.5.1 for another client, on their dedicated server where Umbraco 4.0.2.1 is running quite happily, and where I had also successfully tested 4.5… and exactly the same thing occurred. Both 4.0 and 4.5 seemed to be fine in Integrated Pipeline mode, but 4.5.1 is evidently not.

    Paul, are you running 4.5 or 4.5.1 at Softsys? Because if it's only 4.5, then we may have a serious Umbraco issue with 4.5.1 that needs to be raised. And agreed about Softsys excellent support — another thing I get to be grateful to the Umbraco community for, as I first heard about them on these pages.

  • Paul Blair730 karma points
    Jul 28, 2010 @ 14:39
    Paul Blair
    0

    It was a 4.5 site that I have just upgraded to 4.5.1.

    Still in development though and I haven't done a thorough test but everything looks OK so far.

    When I first released it as 4.5.0 I had exactly the same screen as your screenshot and what I mentioned above rectified the issue.

  • Michael Lawrence198 karma points
    Jul 28, 2010 @ 19:05
    Michael Lawrence
    0

    Well just to let you guys know, I had upgraded a 4.5 to 4.5.1 site and it worked perfectly in Integrated Mode.  Then out of nowhere it stopped working and that's when I got the same error as you. It had been working perfectly for over a week before this happened.  So even though your site is working fine in Integrated Mode now, that doesn't mean it always will. Just a warning :)

  • dcwoodsjr30 karma points
    Jul 29, 2010 @ 19:59
    dcwoodsjr
    0

    I've got the same issue, but turning off the Integrated Pipeline did not do the trick.

    Anybody else got any suggestions?

  • Richard Walters48 karma points
    Jul 29, 2010 @ 20:09
    Richard Walters
    0

    Have you checked the /bin directory for the AjaxControlToolkit.dll? That wasn't my issue, but it's been mentioned elsewhere that its presence is no longer required, and in fact causes serious interface issues… so it should be removed. Otherwise I might suggest stopping and restarting the web site — switching modes is supposed to do that automatically, but it might not be happening via the control panel of a shared hosting environment. (I can't count the number of debugging sessions that have been confused for me by caching and other persistence issues.)

    There's some inconsistency of the details in reports from people who all seem to know what they're doing here. Makes me suspect that there's some other, unidentified environment factor at work here, that determines whether 4.5.1 can live happily under integrated pipeline mode or not. Is anyone else developing the same suspicion, or am I out to lunch on that one?

  • Tom Fulton4439 karma points c-trib
    Jul 29, 2010 @ 20:33
    Tom Fulton
    0

    I had a similar issue with the CSS not loading and not being able to access DependencyHandler.axd.  (I think) I fixed it by setting umbracoUseMediumTrust to true in the web.config

  • Folkert212 karma points
    Jul 29, 2010 @ 21:10
    Folkert
    0

    I had troubles with the dependency handler also: read this post(solved it with some small modifications):

    http://our.umbraco.org/forum/getting-started/installing-umbraco/10808-Clean-Install-of-45-and-no-trees-tried-other-solutions-but-still-not-working!

  • dcwoodsjr30 karma points
    Jul 29, 2010 @ 21:25
    dcwoodsjr
    0

    Still not working...

    I there is no AjaxControlToolkit.dll in the bin folder. And I've changed the Medium Trust level to true.

    I've restarted IIS and not any better...What's even more frustrating is that I moved everything over to a VirtualBox running Server 2008 R2 which is same as our development server and it runs correctly.

    Do you know where the DependencyHandler.axd is located?  I did a search and didn't come up with anything.

     

  • TKH32 karma points
    Jul 29, 2010 @ 22:13
    TKH
    0

    Test site at SoftSys (4.5.1 / Full Trust / 4.0 integrated) was OK last night, but today started to exhibit the same CSS/js problems .

    As was suggested,  turned off Integerated Pipeline and seems to be functioning correctly again. Did not change the trust level - still at "Full."

  • Paul Blair730 karma points
    Jul 29, 2010 @ 22:47
    Paul Blair
    0

    I can confirm that I have a site at SoftSys using 4.5.1 with .NET 4.0 integrated mode. All I can suggest is to double check everything i.e. folder permissions, trust=full is in web.config and IIS settings in Dotnetpanel

  • dcwoodsjr30 karma points
    Jul 29, 2010 @ 23:20
    dcwoodsjr
    0

    Thanks for the help everyone...It ended up being a permission issue.  Network service account didn't rights to access the /css folder.

    One of those things though I thought I had already taken care of.

     

  • Richard Walters48 karma points
    Aug 03, 2010 @ 15:36
    Richard Walters
    0

    Just a note that while I had to mark Michael Lawrence's post as the solution (because it's the action that resolved my problem, ultimately), Paul Blair's posts were also extremely helpful.

    Also a note that I upgraded another SoftSys install to 4.5.1 over the last couple of days, and it seems to be running just fine under Integrated Pipeline mode. What the…?

  • Michael Lawrence198 karma points
    Aug 03, 2010 @ 21:04
    Michael Lawrence
    0

    Yeah it's weird. All my 4.5.1 installations work fine for a few days, but ultimately I end up having to turn off Integrated Pipeline due to this issue.  I'm not sure what's really going on.

  • Daniel Lindstrom271 karma points
    Feb 20, 2011 @ 23:02
    Daniel Lindstrom
    0

    Had the exact same issue. Umbraco v4.6.1 worked for a few hours after install on softsys. Then suddenly the backend stopped working. Turning off integrated pipeline as explained above solved the problem.

  • Amir Khan1076 karma points
    Mar 17, 2011 @ 15:04
    Amir Khan
    0

    Same solution worked for me with 4.7, turning off Integrated Pipeline mode. Any idea why this is? I'd like to find the reason for this problem...

  • Paul Blair730 karma points
    Mar 17, 2011 @ 19:47
    Paul Blair
    0

    Amir,

    You could try putting this in your web.config to make sure it is full trust mode:

      <location path="yoursitename.com" allowOverride="true">
        <system.web>
          <trust level="Full" originUrl="" />
        </system.web>
      </location>

    Also, try giving full permission to the whole website.

    Cheers

    Paul

  • Johan339 karma points
    Oct 24, 2011 @ 11:14
    Johan
    1

    I had the same error but the post marked as the solution in this thread didn't cut it for me. I've had this problem two times now and this blog post had the solution. http://blog.dampee.be/post/2011/10/10/Umbraco-deployment-issues-ClientDependency-error-gone-with-debug3dtrue-on-IIS7-%28SOLVED%29.aspx

    It tells you to update your web.config with the following right after the handlers tag inside the system.webserver tag:

    <handlers accessPolicy="Read, Write, Script, Execute">       <remove name="WebServiceHandlerFactory-Integrated" />       <remove name="ScriptHandlerFactory" />       <remove name="ScriptHandlerFactoryAppServices" />       <remove name="ScriptResource" />       <remove name="Channels" />       <remove name="Channels_Word" />       <remove name="ClientDependency" />       <remove name="SpellChecker" />       <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />       <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />       <add name="ScriptResource" verb="GET,HEAD" path="ScriptResource.axd" preCondition="integratedMode" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />       <add verb="*" name="Channels" preCondition="integratedMode" path="umbraco/channels.aspx" type="umbraco.presentation.channels.api, umbraco" />       <add verb="*" name="Channels_Word" preCondition="integratedMode" path="umbraco/channels/word.aspx" type="umbraco.presentation.channels.wordApi, umbraco" />       <add verb="*" name="ClientDependency" preCondition="integratedMode" path="DependencyHandler.axd" type="ClientDependency.Core.CompositeFiles.CompositeDependencyHandler, ClientDependency.Core " />       <add verb="GET,HEAD,POST" preCondition="integratedMode" name="SpellChecker" path="GoogleSpellChecker.ashx" type="umbraco.presentation.umbraco_client.tinymce3.plugins.spellchecker.GoogleSpellChecker,umbraco" />   </handlers>
  • Lesley142 karma points
    Apr 26, 2012 @ 19:59
    Lesley
    0

    I had the same frustrating issue, and just want to thank Johan above for pointing me in the direction that fixed it.

  • Stan Kosmoseistis21 karma points
    Aug 21, 2012 @ 11:43
    Stan Kosmoseistis
    0

    hello, my problem is not fixed :( After the backend showed up for a few moments (see under) i'm back with the same problem...

     

    Hello,

    Seems to be 'one-answer-for-everybody' is not find yet.

    My problem is fixed at the moment with:

    • changing web.config ---)
      <add key="umbracoUseMediumTrust" value="true" />
      
    • changing server settings (easyhost.be) : ASP.net-setting configuration on domain, in submenu "Compilation and Debugging", I ticked the option:"Switch on debugging" on.

    After this two steps the problem was fixed. Tried to put the value from step 1 back on "false" but the problem was there again. back to "true" alone did not help, so i had to do step two again (first tick out an then tick on) and i saw the backend again.

    Hope the problem won't comeback after working in the backend :-S.

Please Sign in or register to post replies

Write your reply to:

Draft
Our.umbraco.org is the community mothership for Umbraco, the open source asp.net cms. With a friendly forum for all your questions, a comprehensive documentation and a ton of packages from the community.