Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Neil Hartley 6 posts 76 karma points
    May 22, 2017 @ 14:38
    Neil Hartley
    0

    Report still shows changes

    After clicking Full Import, I get the list of actions performed and can see that the Import Processed 135 items, 135 Changes.

    If I then run a report it then says

    Report Processed 135 items, 82 Changes

    Should it not be the case that there should be 0 changes?

    An example of an update would be enter image description here

  • Neil Hartley 6 posts 76 karma points
    Jun 01, 2017 @ 21:17
    Neil Hartley
    0

    Can anyone offer any advice?

  • Neil Hartley 6 posts 76 karma points
    Jun 16, 2017 @ 20:55
    Neil Hartley
    0

    Can anyone help on this?

  • Kevin Jump 985 posts 5475 karma points mvp c-trib
    Jun 27, 2017 @ 09:59
    Kevin Jump
    0

    Hi Niel,

    sorry been away.

    the not very good answer is - it's probibly nothing to worry about.

    the slightly better (but still not ideal) answer - it's the change checker in usync not quite handling the prevalues properly.

    prevalues are stored in umbraco against an ID which changes between versions.

    uSync changes are actually triggered when a exported version of what is on the target site doesn't match the import (this is done in memory) and this can mean that if internal IDs don't match you get a change.

    Now uSync does a lot of checking and ignoring of these internal ids so that they don't come up as false positives. - but looking at above i think that is what is happening.

    if you really wanted to check (and if i was debugging this)

    • I would rename the existing usync/data folder that you are attempting to import and then do a full export to see what the target site thinks the settings are.
    • then i would run something like winmerge against the folders and see what the differences are.
    • there will be a lot because the export/import files do have the ids in - its the comparison code that removes them, but if the file in question is the same bar the ids then thats ok.

    it might also be the order of the properties - they are sorted on export but this doesn't always mean the come out in the order you expect them to. again this isn't something that will cause issues in umbraco, but usync will think the two xml files (source and target) are different because they will be.

    Kevin

Please Sign in or register to post replies

Write your reply to:

Draft