Imagine being paid to improve your favorite CMS!

It could be you! Umbraco HQ are hiring and are looking for both talents and senior developers. Wonderful workplace, friendly colleagues and competitive salary.

Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Kate 261 posts 584 karma points
    Oct 07, 2010 @ 10:30
    Kate
    0

    404 page in a static html page

    Hi

    Instead of creating a 404 error page in the content and use the page ID, can´t I just make a static html page and save it in a folder in the root.
    If possible, what should I write in the config files?

  • Dirk De Grave 4480 posts 5713 karma points admin
    Oct 07, 2010 @ 10:37
    Dirk De Grave
    0

    Can save it anywhere in your umbraco installation, as it won't be processed by umbraco (it's a plain old static html page), just need to update your web.config according to this post.

     

    Cheers,

    /Dirk

  • Kate 261 posts 584 karma points
    Oct 07, 2010 @ 11:17
    Kate
    0

    Can´t see what Im doing wrong

    In my web.config I added this line

    <!--<customErrors mode="RemoteOnly" />-->
        <customErrors mode="On" redirectMode="ResponseRewrite" defaultRedirect="fejlside.aspx" />

    In my umbracosettings.config I change it back to this

    <errors>
    <!-- the id of the page that should be shown if the page is not found -->
    <!-- <errorPage culture="default">1</errorPage>-->
    <!-- <errorPage culture="en-US">200</errorPage>-->
    <error404>1</error404>
    </errors>

    I have placed the fejlside.aspx at the same level as my web.config

    Can you se what else I can do?

  • Dirk De Grave 4480 posts 5713 karma points admin
    Oct 07, 2010 @ 11:41
    Dirk De Grave
    0

    you shouldn't be using the <errors> anymore, only setting the web.config value. Can you set defaultRedirect="/fejlside.aspx"?

     

    Cheers,

    /Dirk

  • Kate 261 posts 584 karma points
    Oct 07, 2010 @ 11:51
    Kate
    0

    I have deleted the <errors> in th umbracosettings.config and and change the path but nothing helps

     

  • Bogdan F. 249 posts 425 karma points
    May 06, 2011 @ 12:32
    Bogdan F.
    0

    I'm having the same problem, I've set in web.config but at least in case of a 404 I still get the "No umbraco document matches the url" page. I remember doing the same for a 4.5.2 website and it worked fine. Did you manage to find a solution?

    EDIT: the problem was in 404handlers.config . I did remove the contents of <NotFoundHandlers>, but not the node itself. Removing it solved it.

Please Sign in or register to post replies

Write your reply to:

Draft