Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Matt 51 posts 172 karma points
    7 days ago
    Matt
    0

    Hello all,

    I seem to be having an issue with Meganav when publishing to a live environment.

    So I had a local host running fine, I've then published my website live and I cant seem to edit/add any menus to my Meganav. Everytime I go todo anything I get the following error;

    Request error: The URL returned a 404 (not found): /App_Plugins/Meganav/Views/settings.html

    I've checked on the live environment and that file is there.

    The only difference is the local host wasn't running in an subfolder.

    Anyone have any ideas?

    Best regards, Matt

  • Nigel Wilson 811 posts 1737 karma points
    6 days ago
    Nigel Wilson
    100

    Hi Matt

    I could be wrong but your comment re subfolder would be my first guess as to the issue.

    What is the full URL of the 404 ?

    It might be that the URL is relative in code, but due to your site being a sub folder, it needs the additional sub folder in the URL to locate the file ?

    Cheers

    Nigel

  • Matt 51 posts 172 karma points
    6 days ago
    Matt
    0

    Hello,

    So the error pops up in the umbraco admin backend, once I click add or edit any of the meganav menu it comes up with the red error at the bottom of the screen.

    Request error: The URL returned a 404 (not found): /App_Plugins/Meganav/Views/settings.html

    If I look at the error message, I don't see my subfolder in the error e.g /subfolder/App_Plugins ect ect

    I've searched my umbraco files and found the following file;

    App_Plugins\Meganav\Js

    Which has the following line;

    view: "/App_Plugins/Meganav/Views/settings.html",

    Which doesn't have my subfolder at the start, I tried adding it but nothing seems to have changed.

    I'm just wondering is there another reference?

    Thanks in advance, Matt

  • Nigel Wilson 811 posts 1737 karma points
    6 days ago
    Nigel Wilson
    0

    Hi Matt

    There could be URL's in any compiled files.

    https://github.com/thecogworks/meganav is the source - have a poke around.

    Shame the developers of the package haven't created a forum for the package so you can easily interact with them.

    Cheers

    Nigel

Please Sign in or register to post replies

Write your reply to:

Draft