Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Damien (Slipoch) 55 posts 328 karma points
    Jul 17, 2017 @ 04:16
    Damien (Slipoch)
    0

    Put an Umbraco Website into a new VS project.

    Only access is the webpage itself.

    I need to be able to transfer the website into a new visual studio project and be able to debug it.

    I thought I had it today, but now it is giving me the error below

    A route named 'umbraco-surface-Classified' is already in the route collection. Route names must be unique.
    

    Unfortunately, I cannot find any development of routes in the Umbraco project and global.asax just has

    <%@ Application Inherits="Umbraco.Web.UmbracoApplication" Language="C#" %>        
    

    In it and nothing else.

    Any and all help appreciated.

  • Alex Skrypnyk 3895 posts 13826 karma points mvp
    Jul 17, 2017 @ 10:47
    Alex Skrypnyk
    0

    Hi Damien

    Do you have a surface controller with 'umbraco-surface-Classified' name?

    Thanks,

    Alex

  • Damien (Slipoch) 55 posts 328 karma points
    Jul 17, 2017 @ 23:36
    Damien (Slipoch)
    100

    Figured it was a surface that was not used. Which turned out to be correct. interesting though, as there was only the one surface file so theoretically it should have worked.

    (I deleted the file)

  • Alex Skrypnyk 3895 posts 13826 karma points mvp
    Jul 19, 2017 @ 13:21
    Alex Skrypnyk
    0

    Agree with you that it's strange, was it in App_Code folder?

    Alex

  • Damien (Slipoch) 55 posts 328 karma points
    Jul 19, 2017 @ 23:02
    Damien (Slipoch)
    0

    There is no App_Code folder.

Please Sign in or register to post replies

Write your reply to:

Draft