Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Brian 77 posts 250 karma points
    Jan 23, 2015 @ 10:02
    Brian
    0

    Gmail SMTP Settings Ver 7.2

    Hi guys,

    I have seen quite afew articles on the above but none for version 7.  Does anybody know what the correct settings should be for routing email through gmail?  For info I have a business account so the email address is a personal address rather than a gmail one.

    Here is my code:

     <smtp from=“[email protected]”>
    <network host="smtp.gmail.com"
    userName=“[email protected]"
    password=“pwdhere” port="465" defaultCredentials="false" enableSsl="true" />
    </smtp>

  • Jan Skovgaard 10761 posts 21147 karma points MVP 4x admin c-trib
    Jan 23, 2015 @ 10:06
    Jan Skovgaard
    100

    Hi Brian

    Are you experiencing any issues with the above setup? At a first glance looks right to me - But I'm thinking that you perhaps need to setup the from email in the /config/umbracoSettings.config

    /Jan

  • Brian 77 posts 250 karma points
    Jan 23, 2015 @ 10:13
    Brian
    0

    Hi Jan,

    Thanks for confirming so quickly. 

    In my umbraco settings I have the following:

     <notifications>
    <!-- the email that should be used as from mail when umbraco sends a notification -->
    <email>[email protected]</email>
    </notifications>

    The reason we need it is because we have a team of contributors around the country and they are writing article remotely with one central administrator publishing the articles.  When I tested just now with a test 'send to publish' I didn't receive an email to confirm something had been written.

    Have I missed something daft?

    Thanks.

  • Jan Skovgaard 10761 posts 21147 karma points MVP 4x admin c-trib
    Jan 23, 2015 @ 10:16
    Jan Skovgaard
    0

    Hi Brian

    Try checking the /App_Data/Logs file to see if it reveals any related info. Usually it appears in there if something is not working when trying to send e-mails.

    And if you're not using it already you should try to use http://smtp4dev.codeplex.com/ - It can make it easier to do e-mail testing when sending.

    /Jan

  • Brian 77 posts 250 karma points
    Jan 23, 2015 @ 10:26
    Brian
    0

    Thanks again Jan.

    Couldn't see anything of use in the logs, I have an ongoing issue with this site and memory leaks as well so I'm wondering if my hosting company have got a couple of settings wrong on the server..

    Thanks anyway.

    P.S.  will mark as a solution for other forum members to say that the Gmail settings for ver 7 were correct but will note that my emails are still not working at this point in time.

  • Jan Skovgaard 10761 posts 21147 karma points MVP 4x admin c-trib
    Jan 23, 2015 @ 10:33
    Jan Skovgaard
    0

    Hi Brian

    Ok, the issue could perhaps also be that the mails are ending up in a cue somewhere then so it's a good idea to get in touch with the hosting company.

    Does it work if you try locally?

    /Jan

  • Jesper Ordrup 955 posts 1319 karma points MVP
    Jan 23, 2015 @ 12:28
    Jesper Ordrup
    0

    I really recommend changing smtp provider to something with a log for everything mailed from websites/services. 

    Try sendgrid.com. 

    best
    Jesper 

Please Sign in or register to post replies

Write your reply to:

Draft