Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Adriano Fabri 310 posts 1008 karma points
    Nov 14, 2017 @ 12:13
    Adriano Fabri
    0

    Could not load all types from...

    Hello, I have a problem with my package During installation of my package in a website running Umbraco v7.5.14, I receive a generic error without any details (I have this problem only with this umbraco version).

    From this moment the website always throw this error:

    Could not load all types from "FALM.Housekeeping, Version=7.6.0.8, Culture=neutral, PublicKeyToken=null" due to LoaderExceptions, skipping:
    . System.TypeLoadException on umbraco.interfaces.IDiscoverable: Unable to load type 'umbraco.interfaces.IDiscoverable' dall'assembly 'interfaces, Version=1.0.6345.13056, Culture=neutral, PublicKeyToken=null'.
    

    In the Trace Log I found this error:

    2017-11-14 12:33:14,029 [P7860/D2/T1] ERROR Umbraco.Core.UmbracoApplicationBase - An unhandled exception occurred
    System.Reflection.ReflectionTypeLoadException: Could not load all types from "FALM.Housekeeping, Version=7.6.0.8, Culture=neutral, PublicKeyToken=null" due to LoaderExceptions, skipping:
    . System.TypeLoadException on umbraco.interfaces.IDiscoverable: Unable to load type 'umbraco.interfaces.IDiscoverable' dall'assembly 'interfaces, Version=1.0.6345.13056, Culture=neutral, PublicKeyToken=null'.
    

    I don't understand where is the problem and I cannot debug it.

    Anyone can help me?

  • David Brendel 705 posts 2493 karma points c-trib
    Nov 14, 2017 @ 12:30
    David Brendel
    0

    Hi Adriano,

    my guess would be that the FALM.Housekeeping package depends on 7.6 and that the interface umbraco.interfaces.IDiscoverable is not present in 7.5.14. And thus the error occurs that the package DLL can't be loaded.

    Regards David

  • Adriano Fabri 310 posts 1008 karma points
    Nov 14, 2017 @ 12:51
    Adriano Fabri
    0

    Thank you for your answer...but I don't use the umbraco.interface.iDiscoverable type.

    I call umbraco interfaces only when I load my package:

    using FALM.Housekeeping.Constants;
    using umbraco.businesslogic;
    using umbraco.interfaces;
    
    namespace FALM.Housekeeping.Applications
    {
        /// <summary>
        /// Application(HkConstants.Application.Alias, HkConstants.Application.Name, HkConstants.Application.Icon, 50)
        /// HkApplication
        /// </summary>
        [Application(HkConstants.Application.Alias, HkConstants.Application.Name, HkConstants.Application.Icon, 50)]
        public class HkApplication : IApplication { }
    }
    
  • Adriano Fabri 310 posts 1008 karma points
    Nov 14, 2017 @ 15:00
    Adriano Fabri
    0

    Oh that's ok...I found it. As you correctly told me, in Umbraco v7.6+, iApplication interface inherits from iDiscoverable, but Umbraco v7.5.14 don't have it

    So I must resolve it.

    I think to realize a version of my package compatible with Umbraco v7.5

    Thank you so much

  • David Brendel 705 posts 2493 karma points c-trib
    Nov 14, 2017 @ 14:47
    David Brendel
    0

    Hi Adriano,

    the IApplication interface inherits from IDiscoverable.

    But the interface is also part of 7.5.14. So not sure what the problem is to be honest.

    Regards David

Please Sign in or register to post replies

Write your reply to:

Draft