Imagine being paid to improve your favorite CMS!

It could be you! Umbraco HQ are hiring and are looking for both talents and senior developers. Wonderful workplace, friendly colleagues and competitive salary.

Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


These support forums are now closed for new topics and comments.
Please head on over to http://eureka.ucommerce.net/ for support.

  • Jesper Ordrup 954 posts 1316 karma points
    May 26, 2015 @ 17:05
    Jesper Ordrup
    0

    Products descriptions disappears

    Client tells us that the solutions product descriptions disappears on several products. It seems to happen 2-3 times a month and on multiple products each time.

    I dont know more about the solution so for know I'm just asking if anyone has experienced this before?

    PLEASE NOTE: This might not be a uCommerce problem but could be caused by some custom import feature behaving badly so please draw any premature conclusions about the fabulous uCommerce.

    best

    jesper

  • Martin 181 posts 740 karma points
    May 27, 2015 @ 12:27
    Martin
    0

    Hi Jesper,

    Which version of uCommerce are your client using? I'm not 100% sure but I think uCommerce in later versions has improved some timing issues when saving to database. If you can tell which version your client use I can possibly go fast through changelog on uCommerce website and look for that improvement. I'm not sure whether that is the cause but it is a worth looking into.

    Best regards Martin

  • Jesper Ordrup 954 posts 1316 karma points
    May 27, 2015 @ 12:31
    Jesper Ordrup
    0

    Hi Martin,

    As soon as I know that I'll bring it here. But just to add to the description: The problem is not when saving the product. It initially saved fine and shows op everywhere but then later .. it disappears.

    Again PLEASE NOTE: This might not be a uCommerce problem but could be caused by some custom import feature behaving badly so please draw any premature conclusions about the fabulous uCommerce.

    Best Jesper

  • Martin 181 posts 740 karma points
    May 27, 2015 @ 18:00
    Martin
    0

    Hi again Jesper,

    Do your customer use security foundation in uCommerce to restrict backend users to languages or features? In that case I know uCommerce had an unintended feature which caused properties on some languages tabs dissapear (due to a flaw in the security foundation).

    Usually the issue was easy to trigger. If you have a site with 3 languages (LangX, LangY and LangZ) and 2 editors (userA and userB). - UserA is administrator and can do everything. - UserB is a product manager which can only maintain product data for LangZ.

    If UserA populate data on a product for LangX and LangY it goes fine. When UserB populate data on same product for LangZ and saves it looks fine for him but data for LangX and LangY has actually dissapeared.

    So if this sounds like your problem then take a look and the changelog for later uCommerce versions and see if a bug has been fixed in security foundation.

    Best regards Martin

Please Sign in or register to post replies

Write your reply to:

Draft