Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


These support forums are now closed for new topics and comments.
Please head on over to http://eureka.ucommerce.net/ for support.

  • Dennis 33 posts 237 karma points
    Apr 09, 2015 @ 16:42
    Dennis
    0

    uCommerce problem

    Hi I just installed Umbraco7 from nuget, open Umbraco and installed uCommerce, from the package repo. This was fine I looked a bit around and everything worked. Then I changed my Users login, created a document type and then a simple content node. I got a call and went for some coffee, got back and now uCommerce is broken?

    Anyone know what might had happened?

    Received an error from the server Failed to retrieve data for application tree uCommerce

    Object reference not set to an instance of an object.

    EXCEPTION DETAILS:

    System.NullReferenceException: Object reference not set to an instance of an object. STACKTRACE:

    at UCommerce.Umbraco7.Security.UmbracoUserService.GetUserInternal(String userName) at UCommerce.Umbraco7.Security.UmbracoUserService.GetCurrentUser() at UCommerce.Security.SecurityService.GetCurrentUser() at UCommerce.Security.SecurityService.CurrentUserIsAdministrator() at UCommerce.Security.SecurityService.ShouldAllowAlways() at UCommerce.Security.SecurityService.UserIsInRole(Role role) at UCommerce.Security.Default.SecurityExtensions.CanCreateProductCatalogGroup(ISecurityService securityService) at UCommerce.Umbraco7.Menu.LoadCatalog.CreateRootNode(XmlTreeNode& rootNode) at umbraco.cms.presentation.Trees.BaseTree.CreateRootNode() at umbraco.cms.presentation.Trees.BaseTree.Initialize() at umbraco.cms.presentation.Trees.BaseTree.get_RootNode() at Umbraco.Web.Trees.ApplicationTreeExtensions.TryGetRootXmlNodeFromLegacyTree(ApplicationTree appTree, FormDataCollection formCollection, UrlHelper urlHelper) at Umbraco.Web.Trees.ApplicationTreeExtensions.TryGetRootNodeFromLegacyTree(ApplicationTree appTree, FormDataCollection formCollection, UrlHelper urlHelper, String currentSection) at Umbraco.Web.Trees.ApplicationTreeController.d12.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Runtime.CompilerServices.TaskAwaiter`1.GetResult() at Umbraco.Web.Trees.ApplicationTreeController.d4.MoveNext()

  • Mads Due 9 posts 29 karma points
    Apr 15, 2015 @ 15:31
    Mads Due
    0

    Hi Dennis,

    I have tried to follow your steps. 1. Installing Umbraco7 from nuget 2. Open and install uCommerce 3. Looked around and edited the user login 4. Then went for some coffee (and wait for 15 minutes).

    Unfortunately, I didn't managed to trigger the exception that you are.

    I used umbraco 7.2.4 and uCommerce 6.6.3.

    Therefore, I think that you have to try installing it again. To work through this problem.

    __ Mads

  • Doug Brott 4 posts 34 karma points
    Jul 20, 2015 @ 18:55
    Doug Brott
    0

    Hopefully you've solved this issue by now. To whomever else may encounter this, read below:

    I just had a very similar issue.

    1. Installed Umbraco using Nuget (v 7.2.6)
    2. Logged in to Umbraco
    3. Changed my username
    4. Installed uCommerce (v 6.7.3.15189)
    5. Clicked on new uCommerce tab and the same server error listed by the poster appeared.

    To resolve this - I simply had to log out and log back in.

Please Sign in or register to post replies

Write your reply to:

Draft