Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

These support forums are now closed for new topics and comments.
Please head on over to for support.

  • Mike Bowen 12 posts 32 karma points
    Jun 10, 2014 @ 12:09
    Mike Bowen

    Checkout pipeline issues using PayPal

    Hi guys

    uCommerce v3.6.4.13211

    Razor Store v1.0.3.13143

    Umbraco v6.1.3

    Seem to be having issues after a payment is taken via PayPal - the Checkout pipeline is not executed, and therefore the client doesn't receive an confirmation email, nor is the purchase order assigned a order id or a order status other than 1 (Basket) in the database. I've checked all the obvious:

    Nothing in the log files that could say why this happening.

    The PayPal payment method points to the Checkout pipeline in the uCommerce_PaymentMethod table.

    The site is public facing.

    The payment appears in PayPal (albeit Sandbox).

    The IPN appears in PayPal, with a 200 HTTP status (it's hitting the correct URL: /8/126/PaymentProcessor.axd)

    Here's the IPN:

    mcgross=835.32 &invoice=Reference-121 &authexp=02:46:34 Jul 10, 2014 PDT &protectioneligibility=Ineligible &itemnumber1= &payerid=Y3EUCR5AQMQRA &tax=0.00 &paymentdate=02:46:34 Jun 10, 2014 PDT &paymentstatus=Pending &charset=windows-1252 &mcshipping=0.00 &mchandling=0.00 &firstname=Mike &transactionentity=auth &notifyversion=3.8 &custom= &payerstatus=unverified &business=[email protected] &numcartitems=1 &mchandling1=0.00 &verifysign=AyDoxrFPCkPRzyLteX7lxpFX8y0AA0vYaG7mgCciPtXbA1nnKQDqARpJ &payeremail=[email protected] &mcshipping1=0.00 &tax1=0.00 &parenttxnid= &txnid=74817510XH3427100 &paymenttype=instant &remainingsettle=10 &authid=74817510XH3427100 &lastname=Bowen &itemname1=Sum &receiveremail=[email protected] &authamount=835.32 &quantity1=1 &receiverid=SHELM4XJBWY8Y &pendingreason=authorization &txntype=cart &mcgross1=835.32 &mccurrency=GBP &residencecountry=GB &testipn=1 &receiptid=1135-1371-9113-9233 &transactionsubject= &paymentgross= &authstatus=Pending &ipntrack_id=e0d1169810e31

    Any help would be awesome.

  • Morten Skjoldager 436 posts 1492 karma points
    Jun 10, 2014 @ 22:25
    Morten Skjoldager

    What is the link to your site? 

  • Mike Bowen 12 posts 32 karma points
    Jun 11, 2014 @ 23:20
    Mike Bowen

    Hi Morten

    It is - but, I've just done an upgrade from v3.6.4.13211 to v6.0.0.14094 and ran another test order - this one went through fine, the upgrade must have restored something or other!

    Cheers Mike

  • Jebastin 32 posts 80 karma points
    Nov 17, 2014 @ 13:48

    Hi Mike,

    I'm facing the same issue. Hope you might have resolved this issue now. It will be helpful for me, if you lemme know the solution for this.


    Jebastin J

  • Mike Bowen 12 posts 32 karma points
    Nov 23, 2014 @ 21:21
    Mike Bowen

    Hi Jebastin

    Sorry for the tardy reply - I didn't dig too deep into the issue to be honest, as I needed to do an upgrade on uCommerce regardless. That seemed to solve the underlying issue. I'd first of all just double (triple!) check everything in the first post has been done / sorted.

    Cheers Mike

  • Søren Spelling Lund 1794 posts 2745 karma points
    Nov 25, 2014 @ 13:15
    Søren Spelling Lund

    Hi Jebastin,

    Which versioun of uCommerce are you using?

    Any info reported in the logs arounds the callback?

Please Sign in or register to post replies

Write your reply to: