Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


These support forums are now closed for new topics and comments.
Please head on over to http://eureka.ucommerce.net/ for support.

  • Jais Edelmann 45 posts 126 karma points
    Feb 06, 2014 @ 22:18
    Jais Edelmann
    0

    Ucommerce in Umbraco 7

    Hey guys, so i decidede to mess around with Umbraco 7 and what better way todo wthat then to use ucommerce, unfornatly it seems that is not running to great in the backend of the new umbraco, when i try and enter a new payment method i dont get any content same with shipping menthod, and when rightclick i only get delete.


    Is there any release plan with dates for ucommerce for umbraco 7?

  • Morten Skjoldager 436 posts 1492 karma points
    Feb 07, 2014 @ 14:56
    Morten Skjoldager
    100

    Hello Jais.

    Our package - as you've experianced are incompatible with Umbraco 7 ATM. We are working on that issue as we speak. However it is a little to early to say anything in specific. However with the work and know issues atm it shouldn't be too long. A month - maybe 2. But yet again. IT is to early to make any promises :) 

    In the meantime you can base your work on a Umbraco 6 and then migrate all the data to Umbraco 7 when the time is. Our data foundation is the same accross 6 and 7.

    Hope that's not too bad news :) 

    Best regards

    Morten

  • Jais Edelmann 45 posts 126 karma points
    Feb 07, 2014 @ 20:42
    Jais Edelmann
    0

    You leave me no choise but to start developing on Umbraco 6 :)

     

    Release isent for a while so i got time, but development is starting up shortly :)


    Thx

  • Alan Ellicott 45 posts 104 karma points
    Mar 03, 2014 @ 12:25
    Alan Ellicott
    0

    Morten,

    I understand what you say re V7.0 of Umbraco but can you confirm that i wont be wasting my time to install developers edition of uCommerce under V6.0 but with defaultRenderingEngine set to MVC in umbracosettings.config.

  • Xavier K 3 posts 23 karma points
    Jul 23, 2014 @ 08:46
    Xavier K
    0

    Morten,

    Any update on this topic?

    I am running Umbraco v7.1.4 and trying to install UCommerce v 6.1.0.14195 but I get errors trying to run it in the admin. It seems its going wrong in the bins.

    FYI: I run it all in VS2013 in a local install

    Thanks, Xavier

     

     

     

     

     

  • Morten Skjoldager 436 posts 1492 karma points
    Jul 23, 2014 @ 09:11
    Morten Skjoldager
    0

    Xavier, what error are you seeing? 

  • Xavier K 3 posts 23 karma points
    Jul 23, 2014 @ 09:14
    Xavier K
    0

    Morten,

    I get following error

    Could not load type 'UCommerce.EntitiesV2.Product' from assembly 'UCommerce, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.TypeLoadException: Could not load type 'UCommerce.EntitiesV2.Product' from assembly 'UCommerce, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

    STACK TRACE

    [TypeLoadException: Could not load type 'UCommerce.EntitiesV2.Product' from assembly 'UCommerce, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.]
       System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMarkHandle stackMark, IntPtr pPrivHostBinder, Boolean loadTypeFromPartialName, ObjectHandleOnStack type) +0
       System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean loadTypeFromPartialName) +70
       System.RuntimeType.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark) +39
       System.Type.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase) +37
       Castle.MicroKernel.SubSystems.Conversion.TypeNameConverter.GetType(String name) +86
       Castle.MicroKernel.SubSystems.Conversion.TypeNameConverter.PerformConversion(String value, Type targetType) +65

    [ConverterException: Could not convert string 'UCommerce.Presentation.Presenters.Catalog.EditProductPresenter, UCommerce.Presentation' to a type.]
       Castle.MicroKernel.SubSystems.Conversion.TypeNameConverter.PerformConversion(String value, Type targetType) +162
       Castle.MicroKernel.SubSystems.Conversion.DefaultConversionManager.PerformConversion(String value, Type targetType) +141
       Castle.MicroKernel.SubSystems.Conversion.DefaultConversionManager.PerformConversion(String value) +127
       Castle.Windsor.Installer.DefaultComponentInstaller.GetType(IConversionManager converter, String typeName) +74
       Castle.Windsor.Installer.DefaultComponentInstaller.SetUpComponents(IConfiguration[] configurations, IWindsorContainer container, IConversionManager converter) +230
       Castle.Windsor.Installer.DefaultComponentInstaller.SetUp(IWindsorContainer container, IConfigurationStore store) +208
       Castle.Windsor.WindsorContainer.RunInstaller() +87
       UCommerce.Infrastructure.ExtendedWindsorContainer..ctor(String xmlFilePath) +438
       UCommerce.Infrastructure.ObjectFactory.GetContainer() +82
       UCommerce.Infrastructure.ObjectFactory.get_Container() +54
       UCommerce.Infrastructure.ObjectFactory.Resolve() +45
       UCommerce.Web.Api.ServiceStackAppHostInit.Initialize() +161

    [InvalidOperationException: The pre-application start initialization method Initialize on type UCommerce.Web.Api.ServiceStackAppHostInit threw an exception with the following error message: Could not convert string 'UCommerce.Presentation.Presenters.Catalog.EditProductPresenter, UCommerce.Presentation' to a type..]
       System.Web.Compilation.BuildManager.InvokePreStartInitMethodsCore(ICollection`1 methods, Func`1 setHostingEnvironmentCultures) +556
       System.Web.Compilation.BuildManager.InvokePreStartInitMethods(ICollection`1 methods) +132
       System.Web.Compilation.BuildManager.CallPreStartInitMethods(String preStartInitListPath, Boolean& isRefAssemblyLoaded) +102
       System.Web.Compilation.BuildManager.ExecutePreAppStart() +153
       System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters, PolicyLevel policyLevel, Exception appDomainCreationException) +516

    [HttpException (0x80004005): The pre-application start initialization method Initialize on type UCommerce.Web.Api.ServiceStackAppHostInit threw an exception with the following error message: Could not convert string 'UCommerce.Presentation.Presenters.Catalog.EditProductPresenter, UCommerce.Presentation' to a type..]
       System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +9885060
       System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +101
       System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +254

  • Xavier K 3 posts 23 karma points
    Jul 29, 2014 @ 13:01
    Xavier K
    0

    Hi Morten,

    Did you get a chance to look at the issue?

    Thanks, Xavier

     

     

  • Tie Penatti 1 post 21 karma points
    Jun 07, 2015 @ 10:00
    Tie Penatti
    0

    Just a bit late here, but I found this topic on google and I had the same exception, took me a bit of time to realize what was wrong, so I am updating here in case someone else is in the same case:

    I was testing the uCommerce and created a vs project which I named "Ucommerce", installed umbraco via nugget, compiled and run, no problems. I was able to install the package uCommerce and the demo store, and played a bit. Then the first time I stoped the debugger and rebuild the project, the dll on the bin folder UCommerce.dll (the one that contains the definition of UCommerce.EntitiesV2.Product, for example, which was copied from the package installer) was replaced with my project dll (with conflicting name) that does not have the definition of Product, then the exception was being raised. So I renamed the project and the assembly in the project properties, application tab, and manually overwrited the Ucommerce.dll on bin folder with the one from the zip package downloaded from their site and it worked again...

    Never a good idea to name your project the same name as third party components :)

Please Sign in or register to post replies

Write your reply to:

Draft