Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


These support forums are now closed for new topics and comments.
Please head on over to http://eureka.ucommerce.net/ for support.

  • Wouter 49 posts 76 karma points
    Jul 08, 2013 @ 11:38
    Wouter
    0

    uCommerce Razor Demo Store: GetProductVariations Exception

    Hi,

    Using umbraco 4.11.10, uCommerce 3.6.3.13183 and uCommerce_Demo_Store_-_Razor_1.0.3.13143 (.NET 4.0)

    When I browse the DEMO store (/demo-store/black-white-wonderland-mood-slim-fit-signature-shirt-limited-edition-%5b200-pieces%5d/c-24/p-105) the ucommerceApi fires an exception:

    http://ucommerce.local/ucommerceapi/Json/SyncReply/GetProductVariations

    {
    • ResponseStatus: {
      • ErrorCode"KeyNotFoundException",
      • Message"The given key was not present in the dictionary.",
      • StackTrace" at System.Collections.Generic.Dictionary`2.get_Item(TKey key) at ServiceStack.WebHost.Endpoints.Utils.FilterAttributeCache.GetRequestFilterAttributes(Type requestDtoType) at ServiceStack.WebHost.Endpoints.EndpointHost.ApplyRequestFilters(IHttpRequest httpReq, IHttpResponse httpRes, Object requestDto) at ServiceStack.WebHost.Endpoints.GenericHandler.ProcessRequest(IHttpRequest httpReq, IHttpResponse httpRes, String operationName)"
      }
    }

    I guess it has something to do with the endpoints... I hope you guys can help me out here because I wanted to demo the store to a client of ours tomorrow.

  • Wouter 49 posts 76 karma points
    Jul 08, 2013 @ 11:43
    Wouter
    0

    The api is set in the web.config in the umbraco-reserved paths and:

    <location path="ucommerceapi">

    <system.web>

    <httpHandlers>

    <add path="*" type="ServiceStack.WebHost.Endpoints.ServiceStackHttpHandlerFactory, ServiceStack" verb="*" />

    </httpHandlers>

    </system.web>

    <system.webServer>

    <modules runAllManagedModulesForAllRequests="true" />

    <validation validateIntegratedModeConfiguration="false" />

    <handlers>

    <add path="*" name="ServiceStack.Factory" type="ServiceStack.WebHost.Endpoints.ServiceStackHttpHandlerFactory, ServiceStack" verb="*" preCondition="integratedMode" resourceType="Unspecified" allowPathInfo="true" />

    </handlers>

    </system.webServer>

    </location>

  • Wouter 49 posts 76 karma points
    Jul 08, 2013 @ 11:46
    Wouter
    0

    http://ucommerce.local/ucommerceapi/Json/SyncReply/GetVariantSkuFromSelection gives me the same exception, adding something to the basket does not work.

  • Wouter 49 posts 76 karma points
    Jul 09, 2013 @ 09:36
    Wouter
    0

    Tried with a clean Umbraco installation with an empty web application and an empty MVC3 application. No go.

  • Mikkel Olsen 20 posts 94 karma points
    Jul 10, 2013 @ 09:53
    Mikkel Olsen
    0

    Im listening too, since I encounter the same errors. Have you tried with a Umbraco 6.0.7 installation, Wouter?.

    EDIT: I can confirm that my Razor Demo Store is working properly after making a clean umbraco installation version 6.0.7.

  • Søren Spelling Lund 1791 posts 2731 karma points
    Jul 29, 2013 @ 15:00
    Søren Spelling Lund
    0

    Hi Wouter,

    You can always use the live demo site to demo to clients. It's available at http://demo.ucommerce.net

    Regarding the issue you're seeing are we dealing with a clean install or did you update the Razor store at any point?

  • fabrice 104 posts 227 karma points
    Aug 21, 2013 @ 15:01
    fabrice
    0

    Hello,

    I have the exact same problem with :

    • uCommerce Demo Store - Razor 1.0.3.13143
    • uCommerce 3.6.4.13211
       
    • A clean new umbraco 6.1.3 install with webform.
    Søren, do you have anyidea why ? is it something you are working on ? are should I try to debug it myself ?
    For info, if I add <componentid="ServiceStackApi"service="uCommerce.RazorStore.ServiceStack.AppHost, uCommerce.RazorStore"type="uCommerce.RazorStore.ServiceStack.AppHost, uCommerce.RazorStore"lifestyle="Singleton"/> in the  /ucommerce/configuration/core.config then all Razor macro with uCommerce access crashes. I guess it shouldn't be there anymore...
  • Søren Spelling Lund 1791 posts 2731 karma points
    Aug 27, 2013 @ 08:06
    Søren Spelling Lund
    0

    Hi Wouter,

    Could you post the exact steps you performed to install Umbraco, uCommerce, and the Razor store? More specific the better.

    I'd like to see if I can repro the issue on my end.

    Thanks.

  • fabrice 104 posts 227 karma points
    Sep 05, 2013 @ 15:24
    fabrice
    0

    Hello,

     

    I found out what the problem was for me : I have included in my VS project the file /Services/uCommerceApiRegistration.cs

    Tips : don’t do that :)

  • vo anh vu 1 post 21 karma points
    Jun 16, 2015 @ 06:39
    vo anh vu
    0

    dll run in 32bit

    enable 32bit app = true

Please Sign in or register to post replies

Write your reply to:

Draft