Imagine being paid to improve your favorite CMS!

It could be you! Umbraco HQ are hiring and are looking for both talents and senior developers. Wonderful workplace, friendly colleagues and competitive salary.

Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Al Burns 30 posts 120 karma points
    Feb 26, 2016 @ 14:42
    Al Burns
    1

    Can't use SEOChecker on doc type located under a folder in Umbraco 7.4.1

    Umbraco 7.4.1 now allows you to create a folder under Settings - Document Types. However, if you add SEOChecker to a document type nested under a folder then it doesn't work. For example, given this document type structure:

    enter image description here

    Adding a content node of type "Test Page" results in this (with an associated angularJS type error "Cannot read property 'seoTitle' of null" thrown in the developer console):

    enter image description here

    Attempting to save and publish results in this exception:

    enter image description here

    If the document type is created at the root then all is well.

    If this is a known issue then can you confirm if there is a workaround to get this working, otherwise this could be a new bug.

  • Al Burns 30 posts 120 karma points
    Apr 04, 2016 @ 15:02
    Al Burns
    0

    Hi. Just wondered if anyone had any ideas on this?

  • Richard Soeteman 3258 posts 9306 karma points
    Apr 04, 2016 @ 15:08
    Richard Soeteman
    0

    Sorry didn't see this one, but it's fixed in SEOChecker 1.9.4 (latest version).

    Hope this helps.

    Best,

    Richard

  • Al Burns 30 posts 120 karma points
    Apr 04, 2016 @ 15:12
    Al Burns
    0

    Great, I'll check it out. Thanks for your reply.

  • Nils Frank 19 posts 89 karma points
    Feb 01, 2017 @ 14:02
    Nils Frank
    0

    We have kinda the same problem. It looks exactly the same, but we have it no matter where we add the document typ.

    I set up a clean umbraco 7.5.8 without any starterkit, installed the SEOChecker Package.

    Then i added a documenttype with the seo checker.

    And now I have the same problem.

    In angular model.value never gets a value and is always undefined.

    Best regards Nils

  • Richard Soeteman 3258 posts 9306 karma points
    Feb 01, 2017 @ 14:08
    Richard Soeteman
    0

    Hi Nils,

    Propably caching. This is not the same issue. Increase version number in /config/clientdependency.config and clear browser cache. Then it should be solved.

    Hope this helps,

    Richard

  • Nils Frank 19 posts 89 karma points
    Feb 01, 2017 @ 14:13
    Nils Frank
    0

    Hi Richard,

    I tried that, both with Chrome and Firefox, but no difference.

    Best regards Nils

  • Richard Soeteman 3258 posts 9306 karma points
    Feb 01, 2017 @ 14:23
    Richard Soeteman
    0

    Maybe there is a dll missing, can you check the umbraco log file for errors?

  • Nils Frank 19 posts 89 karma points
    Feb 01, 2017 @ 14:26
    Nils Frank
    0

    The log file has the following error:

    2017-02-01 15:12:14,663 [P1528/D2/T18] ERROR SEOChecker.DataTypes.PropertyEditors.PropertyEditorWrappers.SEOCheckerPropertyWrapper - SEOChecker: Error converting DB values to editor values
    Microsoft.CSharp.RuntimeBinder.RuntimeBinderException: 'System.Dynamic.ExpandoObject' does not contain a definition for 'alias'
       at CallSite.Target(Closure , CallSite , Object )
       at System.Dynamic.UpdateDelegates.UpdateAndExecute1[T0,TRet](CallSite site, T0 arg0)
       at umbraco.cms.businesslogic.propertytype.PropertyType..ctor(Int32 id)
       at umbraco.cms.businesslogic.property.Property..ctor(Property property)
       at umbraco.cms.businesslogic.Content.<InitializeProperties>b__f(Property x)
       at System.Linq.Enumerable.WhereSelectEnumerableIterator`2.MoveNext()
       at System.Collections.Generic.List`1.InsertRange(Int32 index, IEnumerable`1 collection)
       at umbraco.cms.businesslogic.Content.InitializeProperties()
       at SEOChecker.Core.Umbraco.DocumentWrappers.UmbracoDocument..ctor(Document doc, IContextInfo info)
       at SEOChecker.DataTypes.PropertyEditors.PropertyEditorWrappers.SEOCheckerPropertyWrapper.ConvertDbToEditor(Property property, PropertyType propertyType, IDataTypeService dataTypeService)
    

    and

     2017-02-01 14:16:54,570 [P19620/D3/T13] ERROR SEOChecker.DataTypes.Events.SetSEOValuesFromMappedProperties - Error saving mapped meta data
    Microsoft.CSharp.RuntimeBinder.RuntimeBinderException: 'System.Dynamic.ExpandoObject' does not contain a definition for 'alias'
       at Umbraco.Core.Cache.HttpRuntimeCacheProvider.GetCacheItem(String cacheKey, Func`1 getCacheItem, Nullable`1 timeout, Boolean isSliding, CacheItemPriority priority, CacheItemRemovedCallback removedCallback, CacheDependency dependency)
       at Umbraco.Core.Cache.HttpRuntimeCacheProvider.GetCacheItem(String cacheKey, Func`1 getCacheItem, Nullable`1 timeout, Boolean isSliding, CacheItemPriority priority, CacheItemRemovedCallback removedCallback, String[] dependentFiles)
       at Umbraco.Core.Cache.DeepCloneRuntimeCacheProvider.GetCacheItem(String cacheKey, Func`1 getCacheItem, Nullable`1 timeout, Boolean isSliding, CacheItemPriority priority, CacheItemRemovedCallback removedCallback, String[] dependentFiles)
       at umbraco.cms.businesslogic.ContentType.get_PropertyTypes()
       at SEOChecker.Core.Helpers.UmbracoDocumentHelper.GetPropertyAliasByDataType(String doctype, Guid dataTypeId)
       at SEOChecker.DataTypes.Events.SetSEOValuesFromMappedProperties.(IContentService , SaveEventArgs`1 )
    
  • Richard Soeteman 3258 posts 9306 karma points
    Feb 01, 2017 @ 14:37
    Richard Soeteman
    0

    That error comes from the propertyeditor converter

    Make sure that you have the correct syntax in the template

     var meta = Model.Content.GetPropertyValue<SEOChecker.MVC.MetaData>("seoChecker");
    
    @meta.AllTags
    
  • Nils Frank 19 posts 89 karma points
    Feb 01, 2017 @ 14:43
    Nils Frank
    0

    I had nothing in my template.

    Now i added your lines, but still the same error.

    Visual Studio shows the exception now:

    'System.Dynamic.ExpandoObject' does not contain a definition for 'alias'
    
  • Richard Soeteman 3258 posts 9306 karma points
    Feb 01, 2017 @ 14:46
    Richard Soeteman
    0

    really weird, works fine here and have not heard anyone with the same problem :-(. The issue you are posting is was something completely different..

    If you can share your environment I can have a look in debug mode?

  • Nils Frank 19 posts 89 karma points
    Feb 01, 2017 @ 14:53
    Nils Frank
    1

    Sure, i'm gonna zip the solution and put it on dropbox.

    I'll send you the link in the mail.

    Best regards Nils

  • Richard Soeteman 3258 posts 9306 karma points
    Feb 01, 2017 @ 14:58
    Richard Soeteman
    0

    Thanks, will have a look tomorrow.

  • Marco Teodoro 35 posts 98 karma points
    Apr 21, 2017 @ 15:27
    Marco Teodoro
    0

    Hi Richard,

    i've the same issue, did you found the solution for this?

Please Sign in or register to post replies

Write your reply to:

Draft