Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Craig100 851 posts 1756 karma points c-trib
    Dec 18, 2015 @ 21:21
    Craig100
    0

    Error in PageNotFound Module

    Umb V7.3.3, SEO Checker V1.9.4

    Trace logs filling up with the following, getting one several times a minute.

    SEOChecker.HttpModules.UrlModule

    SEOChecker: Error in PageNotFound Module
    System.NullReferenceException: Object reference not set to an instance of an object.
       at Umbraco.Web.Routing.DefaultUrlProvider.GetUrl(UmbracoContext umbracoContext, Int32 id, Uri current, UrlProviderMode mode)
       at Umbraco.Web.Routing.UrlProvider.<>c__DisplayClass3.<GetUrl>b__0(IUrlProvider provider)
       at System.Linq.Enumerable.WhereSelectArrayIterator`2.MoveNext()
       at System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source, Func`2 predicate)
       at Umbraco.Web.Routing.UrlProvider.GetUrl(Int32 id, Uri current, UrlProviderMode mode)
       at SEOChecker.Core.Repository.PageNotFound.PageNotFoundResult.get_ValidForRedirect()
       at SEOChecker.HttpModules.UrlModule.(Object , EventArgs )
    

    Any help appreciated

  • Richard Soeteman 3265 posts 9319 karma points
    Dec 21, 2015 @ 06:40
    Richard Soeteman
    0

    Hi Craig,

    Make sure seochecker.MVC.dll is in the /bin folder.

    Best,

    Richard

  • Craig100 851 posts 1756 karma points c-trib
    Dec 21, 2015 @ 07:38
    Craig100
    0

    Hi Richard,

    It is.

    Craig

  • Ajay Karwal 31 posts 149 karma points
    Jan 05, 2016 @ 12:41
    Ajay Karwal
    0

    Just bumping this to hopefully get an answer.

    I'm working on the same project as Criag so exact same error... still no solution.

Please Sign in or register to post replies

Write your reply to:

Draft