Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Neil Hartley 6 posts 76 karma points
    May 03, 2017 @ 16:47
    Neil Hartley
    0

    uSync not importing some changes

    I've just installed uSync today and am having trouble getting it to import 15 of my (x total) updates.

    I'm not getting any failures or any indication from the log files that ive had any issues.

    After running the import, I then run the report again expecting there to be no changes, yet I have the same 15.

    An example change shows the following details:

    Action | Delete Path | .Core Name | Folder Old Value | Folder New Value | -

    The def file produced looks like:

    10dbaa85-033d-4de6-9b43-5dd35f2b6df2 Testimonials testimonials icon-forms-table folder.png False True sEO Testimonials testimonial

    If I export the doc type its trying to update, it looks ever so slightly different:

    Testimonials testimonials icon-forms-table folder.png False True sEO Testimonials testimonial

    Any help you can be would be greatly appreciated.

  • Kevin Jump 944 posts 5094 karma points mvp c-trib
    May 03, 2017 @ 18:55
    Kevin Jump
    0

    Hi Niel,

    it's a bit hard to read the values in the post (just formatting in the forum) but i am going to take a guess.

    it's possibly, the template values .

    when you copy the usync folder you also need to ensure the views / master pages folders are also in sync.

    if you look the doctypes have probably synced fine, but they may not have the template set because when the templates are imported if the template files are not in place then they might not import identically.

    the diffrent between an export and usync files as you will see are the key ids' these are used to match values between installs, generally these values are synced as part of the process so you don't need to worry about them.

  • Neil Hartley 6 posts 76 karma points
    May 09, 2017 @ 14:48
    Neil Hartley
    0

    Hi kevin,

    Sorry about the late reply, unfortunately got taken off this to sort something else out for a bit.

    I've checked the templates and in the cases of the doc types that it still thinks need to be synced, they actually dont have any template associated with them. We have created those doc types and used them in a standard mvc partial view that inherits from inherits UmbracoTemplatePage.

    There are also 2 IDataTypeDefinitions that keep coming back after doing an import, ie generate report -> import -> generate report. Always the same 15 changes.

    enter image description here

  • Neil Hartley 6 posts 76 karma points
    May 16, 2017 @ 16:08
    Neil Hartley
    0

    Anyone have any ideas on this as its stopping me from implementing the uSync solution into our environment which if we can figure this out will be awesome :)

Please Sign in or register to post replies

Write your reply to:

Draft