Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Nadia 26 posts 71 karma points
    Dec 15, 2016 @ 19:38
    Nadia
    0

    Doc Types - Allowed Child Nodes not syncing

    I am using Umbraco 7.5 & Usync 3.2.2.740 and it doesn't recognize and/or sync any changes to the allowed child nodes for Doc Type.

    Is this a known issue? or could I have a something setup incorrectly?

  • Kevin Jump 1036 posts 6084 karma points mvp c-trib
    Dec 15, 2016 @ 22:57
    Kevin Jump
    0

    Hi Nadia,

    do you have some more details as to how you are syncing your umbraco installs.

    I've just done some quick checks with Umbraco 7.5.(6) and uSync 7.2.2.740. and allowed child nodes appears to be syncing fine - both when adding and removing doctypes to the list.

    maybe it might be worth checking that the usync file for the doctype has the correct info in it (find the def.config file in usync\data\Documentypes\ under a folder named with the relevant doctype) The file is xml but you should be able to see if the allowed child nodes in the element. check this is the same on source and target

    if you have done any renames make sure that your deployment/copy has removed them from the target - to be sure delete the target usync folder and copy the new one over from source.

    as a sanity check maybe take a copy of the usync/data folder on the target site and then do a full export - to get a complete copy of what usync thinks is there - then you could do a compare and see if the difference is in the files.

    Kevin

Please Sign in or register to post replies

Write your reply to:

Draft