Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • David 5 posts 75 karma points
    Nov 16, 2016 @ 22:15
    David
    0

    Report showing the same items after import

    Umbraco 7.4.0 uSync.BackOffice 3.2.2.740 uSync.Core 5.5.2.740

    After running a uSync Import or Full Import, running a Report shows the same items that need to be imported. My real issue is one of my data types, with a property editor of Umbraco.CheckBoxList, prevalues are not being synced. The history and logs do not report any errors.

  • Chris Clancy 27 posts 94 karma points
    Nov 18, 2016 @ 12:27
    Chris Clancy
    0

    Hi,

    We are having a similar issue.

    (uSync.BackOffice 3.2.2.740) (uSync.Core 5.5.2.740) Umbraco 7.5.2.

    We have a dev db where doc types/data types have been changed. The uSync files have been pushed to our repo to build on our Azure instance.

    After running a uSync import, the correct changes are in place. After Azure rebuilds again, the same changes appear in the uSync report even though it has made the changes once.

    Everything on dev is ok.

    I'm confused.

  • Kevin Jump 991 posts 5547 karma points mvp c-trib
    Nov 18, 2016 @ 13:41
    Kevin Jump
    0

    Hi

    does the change report - show any details of what it thinks is going to change ?

    Kevin

  • Chris Clancy 27 posts 94 karma points
    Nov 18, 2016 @ 15:59
    Chris Clancy
    0

    Hi Kevin,

    Yes. The report states that it is going to create items that have already been created. Also, when we have deleted items, the report wants to create them again. I have checked the config and there is a delete reference in there for deleted items. I have manually deleted any outstanding reference to such items in the uSync folders in my working branch such as documentTypes,templates etc but they still appear as 'create' items in the report. I'm wondering where else they may be referenced from or if we need to do some kind of reset?

  • Kevin Jump 991 posts 5547 karma points mvp c-trib
    Nov 18, 2016 @ 20:39
    Kevin Jump
    0

    Hi Chris

    it sounds like you still have old files in the usync folder on your server :(

    when you delete something usync will delete the file locally, but if you don't clean up the usync folder as you deploy you can end up with extra stuff on the server, and then you get things either getting added back or getting added and then deleted (because the delete is in a usyncaction.config file)

    ideally you need to clean the usync folder on the server before your deployment process copies the new files over.

    depending on the deployment method this can be easy or hard - that's why I've just added a new feature for the next release of usync - that won't delete the files - instead marking them as old, so when you deploy they will overwrite any files on the disk but not give you ghost deployments.

  • David 5 posts 75 karma points
    Nov 18, 2016 @ 18:31
    David
    0

    @Kevin - the report is correctly showing the details that will change. Than the import is run and everything appears like the import was successful. However, the changes I am after, adding prevalues to drop down list, are not performed. Than a report shows that the same changes need to be performed.

  • Kevin Jump 991 posts 5547 karma points mvp c-trib
    Nov 18, 2016 @ 20:41
    Kevin Jump
    0

    Hi David ,

    I think i need to look into this a bit more- are you using a normal dropdown list - or is it a dropdown list with keys ? or something else ?

    Kevin

  • David 5 posts 75 karma points
    Nov 18, 2016 @ 21:41
    David
    0

    It is a standard Checkbox list:

    Property editor: Checkbox list Property editor alias: Umbraco.CheckBoxList

    The Usync generated file looks like (I scrubbed it a little):

    <?xml version="1.0" encoding="utf-8"?>
    <DataType Name="datTypeName" Key="guid here" Id="Umbraco.CheckBoxList" DatabaseType="Ntext">
      <PreValues>
        <PreValue Id="12" Value="value1" />
        <PreValue Id="13" Value="value2" />
        <PreValue Id="14" Value="value3" />
        ...
      </PreValues>
    </DataType>
    
Please Sign in or register to post replies

Write your reply to:

Draft