Imagine being paid to improve your favorite CMS!

It could be you! Umbraco HQ are hiring and are looking for both talents and senior developers. Wonderful workplace, friendly colleagues and competitive salary.

Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Gordon Saxby 1120 posts 1242 karma points
    Oct 28, 2013 @ 16:15
    Gordon Saxby
    0

    Document type 'HomePage' has a default template 'HomePage' but that template does not use this document type

    I am using Umbraco 6.1.6 and uSiteBuilder branch v3.0.0 from CodePlex. I am getting this error - 

    Document type 'HomePage' has a default template 'HomePage' but that template does not use this document type

    The DocType and Template are called the same, I have tried it with and without a DefaultTemplate definition.

    DocType:

        [DocumentType(Name = "Home Page", IconUrl = "settingDomain.gif",
            AllowedChildNodeTypes = new[] { typeof(LandingPage), typeof(NormalTextPage), typeof(SiteMap) })]
        public class HomePage : NormalTextPage
    Template:
        public partial class HomePage : TemplateBase<DocumentTypes.HomePage>
    What am I doing wrong?!

     

  • Rich Green 2245 posts 3846 karma points
    Oct 28, 2013 @ 17:01
    Rich Green
    0

    Isn't this line incorrect? 

    publicclassHomePage:NormalTextPage
  • Gordon Saxby 1120 posts 1242 karma points
    Oct 28, 2013 @ 17:11
    Gordon Saxby
    0

    Umm, why?

  • Gordon Saxby 1120 posts 1242 karma points
    Oct 28, 2013 @ 17:12
    Gordon Saxby
    0

    And the other thing ... my templates aren't appearing in Umbraco :-(

  • Rich Green 2245 posts 3846 karma points
    Oct 28, 2013 @ 17:15
    Rich Green
    0

    Just didn't look right, we always use a base DocType for this. Sorry I couldn't be more help.

  • Gordon Saxby 1120 posts 1242 karma points
    Oct 28, 2013 @ 17:39
    Gordon Saxby
    0

    It appears as though the "version6API" is actually the latest version of uSiteBuilder, rather than V3.0.0 as stated on the CodePlex home page (http://usitebuilder.codeplex.com/) ... is that correct?

  • Sasa Popovic 77 posts 362 karma points
    Oct 29, 2013 @ 11:38
    Sasa Popovic
    0

    Hi Gordon,

    Yes, the "version6API" branch is the latest one.

    Regards, Sasa

  • Gordon Saxby 1120 posts 1242 karma points
    Oct 29, 2013 @ 11:50
    Gordon Saxby
    0

    Thanks for the clarification Sasa :-)

  • Sasa Popovic 77 posts 362 karma points
    Oct 29, 2013 @ 11:57
    Sasa Popovic
    0

    You are welcome Gordon.

Please Sign in or register to post replies

Write your reply to:

Draft