19 votes

ImageProcessor

Please don't use the forums here for questions and issues. Instead, please use [StackOverflow](https://stackoverflow.com/questions/tagged/imageprocessor) for questions, Gitter for general chitchat, and the Github Issue Tracker for issues.

ImageProcessor & ImageProcessor.Web allows the developer to perform image manipulation using querystring parameters as instructions.

ImageProcessor is included by default in Umbraco v7.1+ but you can use this package to install ImageProcessor into older versions of Umbraco such as v4.10+ or v6. You can also install this package to update to the latest version before it's updated automatically in a future Umbraco release.

If you use Visual Studio it is recommended that you use NuGet to update ImageProcessor, this package is primarily for developers that don't use Visual Studio. NuGet version is available here

The package also includes the full ImageProcessor configuration which Umbraco doesn't include by default, details here

Umbraco default versions of ImageProcessor

Umbraco v7.1.5 to v7.1.8 - ImageProcessor v1.9.5, ImageProcessor.Web v3.3.0
Umbraco v7.1.9 - ImageProcessor v1.9.5, ImageProcessor.Web v3.3.1
Umbraco v7.3.0 - ImageProcessor v2.3.0, ImageProcessor.Web v4.4.0
Umbraco v7.3.6 - ImageProcessor v2.3.2, ImageProcessor.Web v4.5.1
Umbraco v7.4.3 - ImageProcessor v2.3.3, ImageProcessor.Web v4.5.3

Upgrading from v1.x to v2.x

You can use this package to upgrade from the Umbraco included v1.9.5 to ImageProcessor to v2.x.

However if you have previously installed v1 of this Umbraco ImageProcessor package and are upgrading to v2, please uninstall the v1 package before installing the v2 version. Otherwise you will see a YSOD on your site and will need to update the configSections as the namespaces changed from ImageProcessor.Web.Config.* to ImageProcessor.Web.Configuration.*

Full documentation is available at http://imageprocessor.org/

This package currently includes ImageProcessor v2.3.3, ImageProcessor.Web v4.5.3 & ImageProcessor.Web.Config v2.2.5

Note: This package requires your website to be running .NET 4.5 (or above). It has been tested on Umbraco 4.10+.

 

Screenshots

Project owner

James Jackson-South

James Jackson-South

James has 1553 karma points

Project Compatibility

This project is compatible with the following versions as reported by community members who have downloaded this package:
Untested or doesn't work on Umbraco Cloud
7.7.x (untested)
7.6.x (untested)
7.5.x (untested)
7.4.x (100%)
7.3.x (100%)
7.2.x (100%)
7.1.x (100%)
7.0.x (100%)
6.1.x (100%)
6.0.x (100%)

You must login before you can report on package compatibility.

Project Information

  • Project owner: James Jackson-South
  • Contributors: Lee Kelleher , Jeavon Leopold
  • Created: 06/01/2014
  • Current version 2.3.3
  • .net Version 4.0,4.5
  • License Apache 2.0
  • Downloads: 3820

External resources