Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Connie DeCinko 926 posts 1148 karma points
    Jan 23, 2017 @ 20:24
    Connie DeCinko
    0

    Is uCompents still alive?

    I just tried to go to the uComponents website and it shows the site is dead and the domain is for sale. Is this project still alive?

  • Lee Kelleher 3632 posts 12943 karma points admin core mvp c-trib
    Jan 23, 2017 @ 20:29
    Lee Kelleher
    0

    Hi Connie,

    The documentation site is available here: http://ucomponents.github.io/

    I let the domain name expire, it ended up costing me personally.

    As for the project status... I guess inactive is the best term for it. The source-code is still available and there's no reason that bugs can't be fixed and patch releases made.

    For me personally, since using Umbraco v7, (3.5 years ago), I haven't needed to revisit v6 or further uComponents.

    Cheers,
    - Lee

  • Connie DeCinko 926 posts 1148 karma points
    Jan 23, 2017 @ 20:31
    Connie DeCinko
    0

    Thanks Lee. I still have two Umbraco 6.x sites to support and am getting errors recently. Looks like time to upgrade from uComponents 5.5.x. The upgrade fixes the known bug, just hope it won't break anything else. I don't recall all the places its used.

  • Lee Kelleher 3632 posts 12943 karma points admin core mvp c-trib
    Jan 23, 2017 @ 20:38
    Lee Kelleher
    0

    From what I recall, it should be straight forward to upgrade from uComponents v5.x to v6.latest.

    At the time of release I outlined all the potential breaking changes...

    v6.0 - http://ucomponents.codeplex.com/releases/view/97718

    There were no breaking changes in v6.1.x https://github.com/uComponents/uComponents/releases

    I hope this helps?

    Cheers,
    - Lee

  • Connie DeCinko 926 posts 1148 karma points
    Jan 23, 2017 @ 21:05
    Connie DeCinko
    0

    Something changed in uComponents.XsltExtensions.dll enough to cause my iframe XSLT to fail. It's pretty basic:

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE xsl:stylesheet [ <!ENTITY nbsp "&#x00A0;"> ]>
    <xsl:stylesheet
      version="1.0"
      xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
      xmlns:msxml="urn:schemas-microsoft-com:xslt"
      xmlns:umbraco.library="urn:umbraco.library" xmlns:Exslt.ExsltCommon="urn:Exslt.ExsltCommon" xmlns:Exslt.ExsltDatesAndTimes="urn:Exslt.ExsltDatesAndTimes" xmlns:Exslt.ExsltMath="urn:Exslt.ExsltMath" xmlns:Exslt.ExsltRegularExpressions="urn:Exslt.ExsltRegularExpressions" xmlns:Exslt.ExsltStrings="urn:Exslt.ExsltStrings" xmlns:Exslt.ExsltSets="urn:Exslt.ExsltSets"
      exclude-result-prefixes="msxml  umbraco.library Exslt.ExsltCommon Exslt.ExsltDatesAndTimes  Exslt.ExsltMath Exslt.ExsltRegularExpressions Exslt.ExsltStrings  Exslt.ExsltSets ">
    
    <xsl:output method="html" omit-xml-declaration="yes"/>
    
    <xsl:param name="currentPage"/>
    <xsl:param name="iframeSource" select="/macro/source" />
    <xsl:param name="iframeName" select="/macro/name" />
    <xsl:param name="qryString" select="umbraco.library:RequestServerVariables('QUERY_STRING')" />
    
    <xsl:template match="/">
    
        <script type="text/javascript">
            function gotop() {
                scroll(0,0);
            }
            function resizeFrame(f) {
                var size;
                size = f.contentWindow.document.body.offsetHeight + 10;
                $(f).animate({height: size + "px"}, 100);
            }
        </script>
    
        <iframe src="/_AdminTools/{$iframeSource}?{$qryString}" name="oldBC_iFrame" width="100%" height="100%" marginwidth="0" marginheight="0" scrolling="no" frameborder="0" id="oldBC_iFrame" onload="resizeFrame(document.getElementById('oldBC_iFrame'));"></iframe>
    </xsl:template>
    
    </xsl:stylesheet>
    
  • Lee Kelleher 3632 posts 12943 karma points admin core mvp c-trib
    Jan 24, 2017 @ 09:33
    Lee Kelleher
    0

    Hi Connie,

    I'm not sure... there's no mention of uComponents extensions being used in that XSLT. Are you getting an error message?

    Cheers,
    - Lee

  • Connie DeCinko 926 posts 1148 karma points
    Jan 26, 2017 @ 15:41
    Connie DeCinko
    0

    All I get is this:

    Error parsing XSLT file: \xslt\iFrame.xslt
    

    Next I'll see if I can breakdown that xslt and see if I can identify what line is causing the error.

  • Connie DeCinko 926 posts 1148 karma points
    Jan 26, 2017 @ 15:50
    Connie DeCinko
    0

    Ok, this might be more helpful... if I save the xslt with uComponents 5.x there are no errors or issues. After upgrading to uComponents 6.x, I try and save that same xslt with no changes it won't save and throws this error:

    Error occured
    
    System.ArgumentException: An item with the same key has already been added.
    
    Server stack trace:
    at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
    at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
    at umbraco.macro.GetXsltExtensionsImpl()
    at Umbraco.Core.CacheHelper.<>c__DisplayClass2`1.b__0()
    at System.Lazy`1.CreateValue()
    
    Exception rethrown at [0]:
    at System.Lazy`1.get_Value()
    at Umbraco.Core.Cache.HttpRuntimeCacheProvider.GetCacheItem(String cacheKey, Func`1 getCacheItem,   Nullable`1 timeout, Boolean isSliding, CacheItemPriority priority, CacheItemRemovedCallback     removedCallback, CacheDependency dependency)
    at Umbraco.Core.CacheHelper.GetCacheItem[TT](String cacheKey, CacheItemPriority priority,   CacheItemRemovedCallback refreshAction, CacheDependency cacheDependency, TimeSpan timeout, Func`1   getCacheItem)
    at umbraco.macro.GetXsltExtensions()
    at umbraco.macro.AddMacroXsltExtensions()
    at umbraco.presentation.webservices.codeEditorSave.SaveXslt(String fileName, String oldName, String fileContents, Boolean ignoreDebugging)
    
  • Connie DeCinko 926 posts 1148 karma points
    Jan 26, 2017 @ 15:54
    Connie DeCinko
    0

    Ooooo, another issue... just tried to create a new blank xslt and it throws this:

    An item with the same key has already been added.
    
    [ArgumentException: An item with the same key has already been added.]
    System.Lazy`1.get_Value() +9587939
    Umbraco.Core.Cache.HttpRuntimeCacheProvider.GetCacheItem(String cacheKey, Func`1 getCacheItem,  Nullable`1 timeout, Boolean isSliding, CacheItemPriority priority, CacheItemRemovedCallback     removedCallback, CacheDependency dependency) +690
    Umbraco.Core.CacheHelper.GetCacheItem(String cacheKey, CacheItemPriority priority,  CacheItemRemovedCallback refreshAction, CacheDependency cacheDependency, TimeSpan timeout, Func`1   getCacheItem) +373
    umbraco.macro.GetXsltExtensions() +128
    umbraco.macro.AddXsltExtensionsToHeader(String xslt) +130
    umbraco.XsltTasks.Save() +425
    umbraco.presentation.create.dialogHandler_temp.Create(String NodeType, Int32 TypeId, Int32 NodeId,  String Text) +384
    umbraco.presentation.create.xslt.sbmt_Click(Object sender, EventArgs e) +176
    System.Web.UI.WebControls.Button.OnClick(EventArgs e) +118
    System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument) +112
    System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String  eventArgument) +10
    System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +13
    System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +36
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean    includeStagesAfterAsyncPoint) +5563
    
  • Lee Kelleher 3632 posts 12943 karma points admin core mvp c-trib
    Jan 26, 2017 @ 15:54
    Lee Kelleher
    0

    I think it might be this one... http://ucomponents.codeplex.com/workitem/14781

    If you check your "config\xsltExtensions.config" file, if there are any uComponents entries, then remove them.

    Fingers crossed that should work.

    Cheers,
    - Lee

  • Connie DeCinko 926 posts 1148 karma points
    Jan 26, 2017 @ 16:30
    Connie DeCinko
    0

    I took this out of the xsltExtensions.config...

    <ext assembly="uComponents.XsltExtensions" type="uComponents.XsltExtensions.Cms" alias="ucomponents.cms"></ext>
    <ext assembly="uComponents.XsltExtensions" type="uComponents.XsltExtensions.Dates" alias="ucomponents.dates"></ext>
    <ext assembly="uComponents.XsltExtensions" type="uComponents.XsltExtensions.Email" alias="ucomponents.email"></ext>
    <ext assembly="uComponents.XsltExtensions" type="uComponents.XsltExtensions.IO" alias="ucomponents.io"></ext>
    <ext assembly="uComponents.XsltExtensions" type="uComponents.XsltExtensions.Media" alias="ucomponents.media"></ext>
    <ext assembly="uComponents.XsltExtensions" type="uComponents.XsltExtensions.Members" alias="ucomponents.members"></ext>
    <ext assembly="uComponents.XsltExtensions" type="uComponents.XsltExtensions.Nodes" alias="ucomponents.nodes"></ext>
    <ext assembly="uComponents.XsltExtensions" type="uComponents.XsltExtensions.Random" alias="ucomponents.random"></ext>
    <ext assembly="uComponents.XsltExtensions" type="uComponents.XsltExtensions.Request" alias="ucomponents.request"></ext>
    <ext assembly="uComponents.XsltExtensions" type="uComponents.XsltExtensions.Search" alias="ucomponents.search"></ext>
    <ext assembly="uComponents.XsltExtensions" type="uComponents.XsltExtensions.Strings" alias="ucomponents.strings"></ext>
    <ext assembly="uComponents.XsltExtensions" type="uComponents.XsltExtensions.Urls" alias="ucomponents.urls"></ext>
    <ext assembly="uComponents.XsltExtensions" type="uComponents.XsltExtensions.Xml" alias="ucomponents.xml"></ext>
    

    and everything looks good so far. Do I need any of those or are these relics from past versions?

  • Lee Kelleher 3632 posts 12943 karma points admin core mvp c-trib
    Jan 26, 2017 @ 16:33
    Lee Kelleher
    0

    No need for them... they are relics from Umbraco v4! (aww nostalgia) :-)

Please Sign in or register to post replies

Write your reply to:

Draft