Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Faheem Habib 5 posts 25 karma points
    Nov 04, 2015 @ 11:53
    Faheem Habib
    0

    Is uCoponents support umbraco 7.3

    Is uComponent supports umbraco 7.3 and if yes then which version...

    Also, how can be disable ucomponents without running umbraco backend?

  • Lee Kelleher 3633 posts 12973 karma points admin core mvp c-trib
    Nov 04, 2015 @ 11:57
    Lee Kelleher
    0

    Hi Faheem,

    Sorry to say, uComponents isn't fully support in Umbraco v7+.

    You can still install the package and make use of the various helper methods, etc - but the main data-types wont work.

    I'm not sure what you mean about disabling uComponents? If you mean uninstalling the package, then yes that's fine to do so.

    I hope this helps?

    Cheers,
    - Lee

  • Faheem Habib 5 posts 25 karma points
    Nov 04, 2015 @ 12:07
    Faheem Habib
    0

    Hi,

    Thanks lee.

    Actually, I am half way to the process of Upgrading my Umbraco site to v 7.3 and I am getting error as below. If uComponent is not fully supported then how I can I uninstall it without being able to run the CMS abckend? due the below error, I am not able to run the application itself.

    Could not load types from assembly uComponents.DataTypes, Version=5.4.1.0, Culture=neutral, PublicKeyToken=null, errors: Exception: System.TypeLoadException: Could not load type 'umbraco.editorControls.mediapicker.MemberPickerDataType' from assembly 'umbraco.editorControls, Version=1.0.5750.18166, Culture=neutral, PublicKeyToken=null'.

  • Lee Kelleher 3633 posts 12973 karma points admin core mvp c-trib
    Nov 04, 2015 @ 12:15
    Lee Kelleher
    0

    Hi Faheem,

    The latest version of uComponents fixes that specific error.

    I'd suggest installing the latest version of the package, but if the Umbraco back-office is throwing that error, then that's not going to work for you!

    Here's how to fix it...

    Download the NuGet package from here:
    https://www.nuget.org/api/v2/package/uComponents/6.1.0

    The NuGet package is basically a zip file, so you can open that up and find the latest DLLs and drop them into the /bin folder.

    Then that should fix the error you are experiencing.

    Good luck!

    Cheers,
    - Lee

  • Faheem Habib 5 posts 25 karma points
    Nov 04, 2015 @ 12:30
    Faheem Habib
    0

    I have already done that but the DLLs downloaded with 6.1.0 do not have any version information and giving the same error..

  • Lee Kelleher 3633 posts 12973 karma points admin core mvp c-trib
    Nov 04, 2015 @ 12:38
    Lee Kelleher
    0

    Hi Faheem,

    Can you paste in the error here please?

    I'm hoping that it is a different error, as that originally mentions "uComponents.DataTypes, Version=5.4.1.0"

    Thanks,
    - Lee

  • Faheem Habib 5 posts 25 karma points
    Nov 04, 2015 @ 12:50
    Faheem Habib
    0

    Rest of the error was same however Version=5.4.1.0 was changed with Version=0.0.0.0 because all dlls in uComponents.6.1.0 are showing version information as 0.0.0.0.

  • Lee Kelleher 3633 posts 12973 karma points admin core mvp c-trib
    Nov 04, 2015 @ 13:40
    Lee Kelleher
    0

    Thanks Faheem, I just checked the "0.0.0.0" version number ... which looks to be a fault with that release - which sucks! :-(

    The alternative would be to try deleting the "uComponents.DataTypes.dll" and "uComponents.Legacy.dll" from the /bin folder.

  • Halima Koundi 8 posts 79 karma points
    Dec 01, 2015 @ 11:44
    Halima Koundi
    0

    Hi all,

    I am completely new to Umbraco.. I am trying to link two Document types and I have read somewhere the best way to achieve this is to use Multi Node Tree Picker datatype in the uComponents package (on this thread).

    So I went to my Umbraco install , to developer > packages > and installed UComponents , then I ran into troubles :( . My Umbraco install is Version 7.3.1, after reading this thread I found out uComponents is not compatible with Umbraco 7 +. It would have been great to have a warning message on the umbraco admin on the package details to say it will actually break with version 7.

    Thank you!

    PS : the issue I had was a missing method exception I paste it here in case it helps. System.MissingMethodException: Method not found: 'Void umbraco.editorControls.ResourceExtensions.RegisterEmbeddedClientResource(System.Web.UI.Page, System.Type, System.String, umbraco.cms.businesslogic.datatype.ClientDependencyType)'. at uComponents.UI.uComponentsModule.IncludeScripts(Page page, Func`2 filter)

Please Sign in or register to post replies

Write your reply to:

Draft