Imagine being paid to improve your favorite CMS!

It could be you! Umbraco HQ are hiring and are looking for both talents and senior developers. Wonderful workplace, friendly colleagues and competitive salary.

Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Gleb Kaplan 47 posts 123 karma points
    Jan 05, 2016 @ 09:19
    Gleb Kaplan
    0

    Render leBlender control inside grid in back-office- "Cannot render a macro when there is no current PublishedContentRequest"

    I have created a new Grid Editor control with a single property which is content picker. The cshtml view for the editor simply renders the selected item's RTE property. Now, if there is a macro within the RTE content, then the whole control fails to render in the back-office with the following message:

    "Cannot render a macro when there is no current PublishedContentRequest".

    Not sure whether it is LeBlender issue or Umbraco core.

  • Jakub 10 posts 89 karma points
    Jan 06, 2016 @ 00:07
    Jakub
    0

    I suppose this is your fault. I had simillar problem some time ago. Are you sure, there is no 'GetGridHtml' in your partial? It probably makes recursion and thats why it cant be rendered.

  • Kristin Löfgren 4 posts 74 karma points
    May 25, 2016 @ 14:00
    Kristin Löfgren
    0

    I have the same problem. Did you find any solution to this?

  • Farhad 12 posts 45 karma points
    Jun 15, 2017 @ 00:30
    Farhad
    0

    I am also having the same issue. Is there a fix\workaround for this?

Please Sign in or register to post replies

Write your reply to:

Draft