Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Mads Jørgensen 5 posts 35 karma points
    Feb 25, 2010 @ 11:22
    Mads Jørgensen
    0

    Another uploading large files and zip files issue

    Hey all,

    I have an issue with uploading large files (Zip files) to media library.

    I'm not getting the timeout as everyone else, i'm getting a 404 -  File or directory not found page.

     

    I'm trying to upload a 76 mb zip file (Have tried a large tiff file also).

     

    have included the <httpRuntime maxRequestLength="2097151"/> which should be max allowed size right?

     

    running umbraco v 4.0.2.1 (Assembly version: 1.0.3441.17657) on IIS 7 on win 2003 server.

     

    Any ideas?

  • Thomas Höhler 1237 posts 1708 karma points MVP
    Feb 25, 2010 @ 12:12
    Thomas Höhler
    0

    Did you check the permissions for the network service account on the media folder? It needs at least write rights, but for creating folders you mights set full rights.

    hth, Thomas

  • Mads Jørgensen 5 posts 35 karma points
    Feb 25, 2010 @ 12:20
    Mads Jørgensen
    0

    I have no troubles uploading files less than 10 mb it's like a 50 mb border...

  • Thomas Höhler 1237 posts 1708 karma points MVP
    Feb 25, 2010 @ 12:25
    Thomas Höhler
    0

    Ouh, we have set httpRuntime to the following settings:

    <httpRuntime executionTimeout="360" maxRequestLength="990000" />

    and this works for big files > 50 MB without problems

     

  • Mads Jørgensen 5 posts 35 karma points
    Feb 25, 2010 @ 12:29
    Mads Jørgensen
    0

    Nope... The issue here is not the same.. Usually the error will be some runtine errors, when this mentioned line  isn't correct. My issue is, that i'll get an 404 error page inside umbraco. The menu and stuff is still there but the properties area is a 404 error page.

     

    BTW, i've just triet your httpRuntime setting, and it still fails.

  • Robin Overgaard 33 posts 73 karma points
    Feb 25, 2010 @ 13:52
    Robin Overgaard
    107

    To solve this issue navigate to your inetsrv folder in your windows folder.

    cd %winsrv%\system32\inetsrv

    and run this code

    appcmd.exe set config "sitename" -section:requestFiltering -requestLimits.maxAllowedContentLength:size in bytes -commitpath:apphost

    sitename is the name you gave your site in IIS7, and size in bytes is well the maximum upload size in bytes.

    I hope this helps :).

  • Mads Jørgensen 5 posts 35 karma points
    Feb 25, 2010 @ 13:53
    Mads Jørgensen
    0

    Muchas Gracias... It solves the problem... Not even an Umbraco CMS issue, but a ISS7 issue!

  • Robin Overgaard 33 posts 73 karma points
    Feb 25, 2010 @ 13:58
    Robin Overgaard
    0

    woops, minor correction %winsrv% should be %windir%

  • Mads Jørgensen 5 posts 35 karma points
    Feb 25, 2010 @ 14:01
    Mads Jørgensen
    0

    Yeah, thats more like it :-)

  • Nicolás Lope de Barrios 21 posts 42 karma points
    Jul 20, 2010 @ 23:13
    Nicolás Lope de Barrios
    0

    It worked like a charm. Thank you!

  • Steven Moye 9 posts 29 karma points
    Mar 07, 2011 @ 23:59
    Steven Moye
    0

    I'm using umbraco v 4.6.1 (Assembly version: 1.0.4029.25836) and I'm getting the same error, but when attempting to use Zen's solution, I am still not seeing any change. Is this a known bug or am I possibly missing something?

  • Mehmet Karaağaç 1 post 21 karma points
    Nov 13, 2011 @ 16:50
    Mehmet Karaağaç
    0

    thank you Zen :) it looks like it is working :)

  • Maksim 12 posts 34 karma points
    Feb 09, 2012 @ 10:02
  • Eric Schrepel 130 posts 181 karma points
    Jan 16, 2013 @ 18:10
    Eric Schrepel
    0

    Thank God for Google and folks having discovered the two changes that need to happen to allow large Media uploads.

    It would be really great if, during the Media Upload process, if a file is larger than the allowed size, that the user get a "file too large; see administrator to change maximum upload size settings" message rather than misleading "file not found" after the upload completes.

    And for us administrators, make it far more clear that both 1) web.config file maxRequestLength must be changed (maybe put a comment in the default web.config file at that line so users know about the next step...); and 2) must edit the Request Filtering feature in IIS 7 to also increase file size limits.

  • Ali Sheikh Taheri 445 posts 1544 karma points
    Feb 26, 2013 @ 15:50
    Ali Sheikh Taheri
    0

    Thanks zen you are star, it took ages to find the solution. 

    Ali

  • Bo Damgaard Mortensen 689 posts 1125 karma points
    Feb 26, 2013 @ 19:50
    Bo Damgaard Mortensen
    4

    And if you don't have access to the IIS, you can control this in your web.config:

    <security>
            <requestFiltering>
                <requestLimits maxAllowedContentLength="4000000000" />
            </requestFiltering>
        </security>

    Insert this (you might want to change the length value ;-) right before </system.webServer>

     

  • suzyb 446 posts 820 karma points
    May 13, 2013 @ 11:19
    suzyb
    0

    Thanks for posting a solution to this.

Please Sign in or register to post replies

Write your reply to:

Draft