Get Umbraco Certified in October

5 courses in 4 different countries across 2 continents leaves no excuse.

Attend courses in the Netherlands, UK, USA and at Umbraco HQ in Denmark.

See the schedule and read more about our training here.

Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Morten 20 posts 60 karma points
    Dec 12, 2012 @ 11:41

    Admin login gives Value cannot be null

    So i Deployed an umbraco for a client and everything looks fine untill they updated some content, and now the admin section gives and error right after loggin in.


    Server Error in '/' Application.

    Value cannot be null.

    Parameter name: source

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: System.ArgumentNullException: Value cannot be null.

    Parameter name: source

    Source Error: 

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace: 

    [ArgumentNullException: Value cannot be null.

    Parameter name: source]

       System.Linq.Enumerable.SingleOrDefault(IEnumerable`1 source, Func`2 predicate) +2535654

       umbraco.BusinessLogic.User.GetApplications() +273

       umbraco.cms.presentation._umbraco.Page_Load(Object sender, EventArgs e) +63

       System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +51

       System.EventHandler.Invoke(Object sender, EventArgs e) +0

       System.Web.UI.Control.OnLoad(EventArgs e) +92

       umbraco.BasePages.BasePage.OnLoad(EventArgs e) +14

       System.Web.UI.Control.LoadRecursive() +54

       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +772

    So asumming that this is a caching problem i deletede the umbraco.config file, edited the web.config and ran the"+i+"/jquery.min.js",f.onload=f.onreadystatechange=function(){e||(o=this.readyState)&&o!="loaded"&&o!="complete"||(r((u=n.jQuery).noConflict(1),e=1),u(f).remove())},t.documentElement.childNodes[0].appendChild(f))})(window,document,"1.8.0",function(n){var i="Oops! something has gone wrong. Are you logged in?",r={type:"POST",url:"/umbraco/dialogs/republish.aspx?xml=true",success:function(n,t,r){if(!n.length||n.indexOf("umbraco/logout.aspx")!==-1){this.error(r,t,i);return}alert("Whoop! Cache cleared.")},error:function(n,t,r){r.length||(r=i),alert(r)}};n.ajax(r)});" href="chrome-devtools://devtools/devtools.html?docked=true&dockSide=bottom&toolbarColor=rgba(223,223,223,1)&textColor=rgba(0,0,0,1)" target="_blank" rel="nofollow">/umbraco/dialogs/republish.aspx?xml=true url.

    but the problem seems to not be effekted by caching.


    any ideas?




  • Abtin Ghods59 karma points
    Dec 20, 2012 @ 09:11
    Abtin Ghods

    Im having the same issue on my local with Umbraco version 4.11.1 

    I dont remmebr having updated any content the other day when everything was working. Today just when i tried to loging to admin im keep getting this error!

  • Abtin Ghods59 karma points
    Dec 20, 2012 @ 09:52
    Abtin Ghods

    Refer to this post

    Fixed my issue (after copying config file from my backup)

  • Morten60 karma points
    Dec 20, 2012 @ 10:25

    Oh, i totally forgot to get back to this one, but yes it semse that multiple files had been corrupted, and unreadeble or no longer beening .config files, i did a full upload of systems files for umbraco and everthing worked agian.

  • Hardball Consulting141 karma points
    Jan 10, 2013 @ 07:30
    Hardball Consulting

    I can confirm that I had the same problem and redeploying the config files from backup resolved it for me too.

    Thanks Abtin & Morten!


  • Ivan Thorsen56 karma points
    Feb 07, 2013 @ 12:36
    Ivan Thorsen

    I have got the same error on 4.9.0 as well - and solved the problem by redeploying the config files.

    This has never occured on our primary webhotel partner (Scannet) and this happens after the site has been online for about 6 months on another webhotel partner (Binero)

    Anybody knows why this happens?

  • Fredrik Rofors23 karma points
    Jun 11, 2014 @ 14:45
    Fredrik Rofors

    I got the same error on Umbraco v6.1.6 (Assembly version: 1.0.5021.24867).

    The site had been running in production for 4 months without any problems (or re-deploys).

    Looking at the config files I could see that the application.config file was empty (for unknown reasons), so re-deploying that file solved the problem.


  • Melissa Snell34 karma points
    Jul 17, 2014 @ 16:04
    Melissa Snell

    I had the same error on a live site v6.1.3. Some of the config files were 0Kb for some reason e.g. Application and Trees. REplaced files and was able to log in to CMS without error

Please Sign in or register to post replies

Write your reply to:

Draft is the community mothership for Umbraco, the open source cms. With a friendly forum for all your questions, a comprehensive documentation and a ton of packages from the community. This site is running Umbraco version 7.3.0