Last chance to get discounted tickets to Codegarden... Price goes up on Tuesday at 20:00 CEST!

Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Paul A 133 posts 368 karma points
    Oct 15, 2010 @ 13:10
    Paul A
    1

    404 page settings not working

    Hi all,

    I've updated umbracoSettings.config

    <error404>1234</error404>

    with the correct page ID but this doesn't seem to work. Have restarted (edit web.config) but still not being picked up. Just get IIS message

    The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

    Thanks.

     

  • Rik Helsen 670 posts 873 karma points
    Oct 15, 2010 @ 15:03
    Rik Helsen
    0

    Always configure it both in IIS as Umbraco, depending on which of both is handling the error (depends on extension of the mistyped url)

  • Paul A 133 posts 368 karma points
    Oct 15, 2010 @ 15:41
    Paul A
    0

    Thanks. I did that (set in IIS7) and it's all working now. Cheers

  • Paul A 133 posts 368 karma points
    Nov 19, 2010 @ 16:52
    Paul A
    0

    Hi again,

    Problem is back, but in a different form. If I try to visit

    mysite.com/somename

    I get my lovely custom 404 page. but if I visit

    mysite.com/somename.aspx

    I get the "this page has been left intentionally ugly" Umbraco page. Any ideas?

     

  • Paul A 133 posts 368 karma points
    Nov 30, 2010 @ 15:26
    Paul A
    0

    for anyone stuck on this, you need to remove poetpatcher info from 404handers.config. See http://our.umbraco.org/forum/templating/templates-and-document-types/13923-Unable-to-get-custom-404-page-to-work

  • Zac 221 posts 484 karma points
    Jan 12, 2011 @ 18:55
    Zac
    0

    Thanks Paul.  The poetpatcher tip helped out a bunch

  • ryanjenns 1 post 21 karma points
    Jun 17, 2011 @ 00:08
    ryanjenns
    0

    Hi,

    I have a different twist on this problem that I am hoping you can help with.

    The umbracosettings.config is set and when I try to hit www.domain.com/somename.aspx I get the correct 404 page. However if I hit www.domain.com/somenamewithnoextension   I get the "The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable." message.

    Is this an IIS setting when file extensions are missing or incomplete or is this set on the server?
    Thanks
    R-

  • Flavio Spezi 127 posts 309 karma points
    Dec 12, 2013 @ 18:28
    Flavio Spezi
    3

    I would tell to community my personal experience.

    I changed /Config/umbracoSettings.config file. I set the ID of my page that will be manage Error404.

    <settings>
        <content>
            <errors>
                <error404>1234</error404>
            </errors>
        </content>
    </settings>
    

    Then I try the feature.
    I open /notExistsUrl and /notExistsUrl.aspx: I receive my error404 page.
    I open /notExistsUrl.asp and /notExistsUrl.php: I receive IIS standard 404 error page.

    I solved this issue adding this in /web.config file.

    <configuration>
        <system.webServer>
            <httpErrors>
                <remove statusCode="404" subStatusCode="-1" />
                <error statusCode="404" prefixLanguageFilePath="" path="/error404" responseMode="ExecuteURL" />
            </httpErrors>
        </system.webServer>
    </configuration>
    
  • Hayden 31 posts 165 karma points
    Nov 01, 2017 @ 21:39
    Hayden
    0

    The web.config changes within this comment worked a treat for me.

    Thanks Flavio

Please Sign in or register to post replies

Write your reply to:

Draft