Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Geofrey 34 posts 134 karma points
    1 week ago
    Geofrey
    0

    I can't login to umbraco back office

    I've tried resetting the password via the database using this command :

    UPDATE umbracoUser set userdisabled=0, userPassword='/7IIcyNxAts3fvQYe2PI3d19cDU=' where id=0 
    

    and these values -

    userPassword Value : bnWxWyFdCueCcKrqniYK9iAS+7E= Password : default
    userPassword Value : d9xnUXsUah9gycu7D0TpRYcx19c= Password : admin
    userPassword Value : /7IIcyNxAts3fvQYe2PI3d19cDU= Password : password
    

    also changed the following in proces:

    1.useLegacyEncoding="false" to true
    2. Hashed to Clear 
    

    NB: I am using localhost server

    All didn't work.

    The version of Umbraco i am using is 7.7.6
    

    Any help would be appreciated.

    Thanks

  • Alex Skrypnyk 4267 posts 15412 karma points
    1 week ago
    Alex Skrypnyk
    0

    Hi Geofrey

    Is database connection working? Can you check the log also?

    /Alex

  • Geofrey 34 posts 134 karma points
    1 week ago
    Geofrey
    0

    Hii

    Bro everything works perfectly if the connection wasn't working I couldn't manage to get login page to Umbraco cms right?

    I tried everything but nothing those method provided in Umbraco forums for resetting Umbraco user password ain't working in new version of Umbraco,

    Please if anyone knows or have some friends who work at Umbraco can you ask them to help me out on this?

    NOTE: Those methods above works only on older versions of Umbraco

  • Daniel Chenery 75 posts 308 karma points
    1 week ago
    Daniel Chenery
    0

    I'm on my phone, so can't confirm, but I believe you need to set the userNoConsole(or similar) column to 0 too

    Obviously backup your database before running any queries

  • Shannon Deminick 1415 posts 4693 karma points core hq
    1 week ago
    Shannon Deminick
    0

    Those passwords you've posted are WITH legacy encoding, the modern passwords don't look like that and are longer.

    you cannot just reset a password to a known hash when useLegacyEncoding="false" for a websites. You should definitely not set this to true for new sites the old hashing isn't very secure these days.

    Do this:

    • Revert your settings back to what they were originally, i assume this means: useLegacyEncoding="false" and Hashed
    • Ensure that your users are not locked, out as Daniel suggests, check your user table for userNoConsole or userDisabled you won't be able to log in if either of those are true ... this could just be your problem
    • You can then do either:
      • Use the Forgot password feature on the login screen - you'll need smtp configured for that
      • Do a password reset trick:
        • Clear the value in your web.config umbracoConfigurationStatus
        • Remove your connection strings
        • Change the password in your DB for user 0 to default
        • Go to the site, it will show the normal installer
        • Enter a username/password
        • Go to advanced and fill out your DB connection information exactly as you had it before
        • Proceed with the install, this will reset user 0's password to the one you entered
  • Geofrey 34 posts 134 karma points
    1 week ago
    Geofrey
    0

    Hii

    Shannon I am trying your method , but stil i have error

    System.Data.SqlClient.SqlException (0x80131904): Cannot find the object "umbracoUserLogins" because it does not exist or you do not have permissions.
    

    NB: I have granted all permission to umbraco user but still shit !!! damn , umbraco why why they complicate like this ? its localhost , can they implement a simple method to reset user forgotten password?

  • Steve Morgan 890 posts 2669 karma points c-trib
    1 week ago
    Steve Morgan
    0

    Hi,

    As an alternative.. (as I bothered to just test this and Shannon posted before me and certainly more right!)

    Put your webconfig back how it was then: Download https://our.umbraco.org/projects/developer-tools/umbraco-admin-reset/ and drop the dll in your bin folder.

    You'll need to allow it to change the password so modify this line in your webconfig to add the allowManuallyChangingPassword to the UsersMembershipProvider

    enter image description here

    Your username will now be Admin and the password Admin1234!

    Remember to change the web.config back.

  • Geofrey 34 posts 134 karma points
    1 week ago
    Geofrey
    0

    Hii Steve Morgan

    I started with your simple and short cut method out there but unfortunatelly this does not work in new version of umbraco 7.7.6

    Thanks for your help though, now am checking Shannon method

  • Steve Morgan 890 posts 2669 karma points c-trib
    1 week ago
    Steve Morgan
    0

    Hi,

    I downloaded 7.7.6 and tested it so you've probably not set back your web.config settings.

    Might be worth doing a diff against a vanilla blank download if Shannon's tips don't work.

    Steve

  • Geofrey 34 posts 134 karma points
    1 week ago
    Geofrey
    0

    I did check here:

    <membership defaultProvider="UmbracoMembershipProvider" userIsOnlineTimeWindow="15">
          <providers>
            <clear />
            <add name="UmbracoMembershipProvider" type="Umbraco.Web.Security.Providers.MembersMembershipProvider, 
    
    Umbraco" minRequiredNonalphanumericCharacters="0" minRequiredPasswordLength="10" useLegacyEncoding="false" enablePasswordRetrieval="false" enablePasswordReset="false" requiresQuestionAndAnswer="false" defaultMemberTypeAlias="Member" passwordFormat="Hashed" allowManuallyChangingPassword="true" />
            <add name="UsersMembershipProvider" type="Umbraco.Web.Security.Providers.UsersMembershipProvider, Umbraco" />
            <add name="DefaultMembershipProvider" type="System.Web.Providers.DefaultMembershipProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="/" />
          </providers>
        </membership>
    
  • Steve Morgan 890 posts 2669 karma points c-trib
    1 week ago
    Steve Morgan
    0

    Just to check you added the allowManuallyChangingPassword attribute flag to the UsersMembershipProvider and didn't just changed the existing on the UmbracoMembershipProvider to true?

  • Geofrey 34 posts 134 karma points
    1 week ago
    Geofrey
    0

    Yep

    And here is data base nothing is changed !

    enter image description here

  • MuirisOG 290 posts 995 karma points
    1 week ago
    MuirisOG
    0

    You are using the email address and not the username (worth a shot).

Please Sign in or register to post replies

Write your reply to:

Draft