Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Jon R. Humphrey 142 posts 355 karma points
    Aug 09, 2017 @ 23:50
    Jon R. Humphrey
    0

    Upgrading from 7.2.6 to latest and I can't even get up to 7.4.x?

    As the title states, I'm currently attempting to update a site for a client from 7.2.6 to the latest in prep to move to an Umbraco Cloud instance.

    So far I have tried to update from:

    • 7.2.6 ~> 7.2.7 => Stuck at non-refreshing redirection screen
    • 7.2.6 ~> 7.2.8 => Upgrade completes but no back office login page, white screen displayed with no errors in console
    • 7.2.6 ~> 7.3.0 => Same as 7.2.8
    • 7.2.6 ~> 7.4.0 => Upgrades, however, Nested Content properties are empty on content nodes in back office BUT front-end renders correctly
    • 7.2.6 ~> 7.4.1 => Upgrades too, however still no Nested Content properties in content nodes AND front-end YSOD's as well with a null reference error on the Nested Content property (which I will fix when the upgrade is sorted!)
    • 7.2.6 ~> 7.4.3 => Upgrades yet once again still no Nested Content in content node properties BUT front end worked again as Matt explained to me this evening:

    "[...] the recommended approach we've suggested in the past is to first upgrade NC, then resave all nodes with NC on them so this will apply the auto fix to switch to doc type aliases, and then do the Umbraco upgrade."

    Which I did!

    So, can anyone please shed light on why each of these attempts to update the core has consistently fallen over and won't let me update the core AND keep the node properties and data types filled?

    Please note that I have updated the ClientDependency version in the CD.config, or web.config, depending on where it was for that specific update; as well as cleared the browser cache to the beginning of time, deleted the /TEMP/ClientDependency directory for each attempted update, and rolled back the changes in both the Git Repo as well as via SQL Server Management Studio 2014 restore tool.

    I'm really confused on what is causing these core errors on updates as well as why it seems to want to remove the NC properties from the content nodes in the back office when they've been updated to the correct value types in the DB?!?!


    If it helps, when I originally received the files, it was explained that everything had been installed via zip files during the initial build process but I felt it was better to handle as much via NuGet as possible inside Visual Studio 2017.

    I was able to overwrite the core instance via NuGet, as well as the following packages which have worked as version 7.2.6 runs fine in the browser and back office.

    So, unless otherwise noted, these packages are now handled by NuGet - the first number is the initial version and the second is the current version:

    • Angular Google Maps ~ v.1.0.7-alpha-000010 ~> 2.0.3
    • Articulate~ v.1.0.9 <= NOT UPDATED YET
    • CMS Import ~ v.3.1.1 <= REMOVED
    • Config Tree ~ v.3.1.0 ~> 3.2.1
    • Diplo Trace Log Viewer ~ v.2.1 ~> 2.3.2
    • Full Text Search ~ v.6.1.2 <= NOT UPDATED YET
    • Nested Content ~ v.0.1.1 ~> 0.4.0
    • RJP.MultiUrlPicker ~ v.1.3.1 ~> 1.3.2
    • Robot.txt Editor ~ v.3.0 <= LATEST ALREADY
    • SearchEngine Sitemap ~ v. 0.0.1 <= NOT UPDATED YET
    • SEO Visualiser ~ v.1.1.0 ~> 1.2.0
    • Slimsy ~ v.1.1.5 ~> 1.1.5
    • Umbraco Forms ~ v.4.1.4 ~> 4.4.3
    • Url Tracker ~ v.3.8 ~> 3.10

    If it hasn't been updated then there are issues with dependencies noted per package and will be handled asap.

    I'm building in VS 2017 Community, git version 2.13.3.windows.1, SQL Server Express 2014, IIS version 10.0.10586.0, 64 Bit Windows 10, Dell XPS 17" i7 1.73Ghz with 16gb Ram

    Any further clarifications or questions please ask and I will strive to answer as best I can!

  • Jon R. Humphrey 142 posts 355 karma points
    Aug 10, 2017 @ 11:15
    Jon R. Humphrey
    100

    I'm closing this post and marking it as solved as the issue with Nested Content not working is not down to the Core updates, but something else which I'm still investigating.

    This was due to the Nested Content not retaining the connection to their corresponding Document Types as described by Lee in the comments below. Reapplying the "missing" property values to their respective DataTypes resolved the missing content in the back office!!!

    NOTE TO SELF: Save Nested Content content nodes as well as data-types on each respective core update to ensure property relationships are maintained!

    Thanks to Sebastiaan's upgrade check post and everyone on the Slack Channel for their help in narrowing down the issues and helping me!

    Thanks also to Lee and Matt for a brilliant package and their dedication and support to the community too!

    #h5yr!

    Cheers! Jon

  • Lee Kelleher 3690 posts 13439 karma points admin core mvp c-trib
    Aug 10, 2017 @ 11:43
    Lee Kelleher
    0

    Hey Jon,

    The crux of the issue with NC is that in Umbraco 7.4.0, all of the DocType GUIDs get changed.

    See Umbraco issue #U4-7286 and v7.4.0 migration script for details.

    The problem you hit was that with NC v0.1.x we referenced the DocType GUID, and with v0.2+ we reference the DocType alias. We added support to convert the GUIDs to aliases ... However if that is done in combination with the upgrade to Umb v7.4, then the GUIDs would have already changed, so NC would literally have zero idea what the alias would be for it :-(

    The only option at that point would be to manually change the JSON for each and every NC data (e.g. in the cmsPropertyData table) ... which is a very ugly option, not fun at all!

    As Matt suggested on Slack, the staggered workflow would be to upgrade NC first - re-saving/re-publishing all the data, (not sure if that could be done in bulk or not). Then once the frontend website is working, then go for the Umbraco upgrade.

    Hope this helps somehow?

    Cheers,
    - Lee

  • Jon R. Humphrey 142 posts 355 karma points
    Aug 10, 2017 @ 12:01
    Jon R. Humphrey
    0

    Thanks Lee!

    Matt did say the same and so I did exactly that - saved each content node with NC content again while still core version 7.2.6 and NC version 0.4.0 checked the DB and umbraco.config for GUID's in any property value prefixed with "ncContentTypeAlias" to which there were none that weren't the actual alias and both the front end and the back office showed the Nested Content as expected:

    umbraco.config

    DB Search Results

    When I updated the core to 7.4.x, as described above, currently the front end still shows the Nested Content BUT the back office shows empty node content for the tabs with NC properties:

    no nested content

    Any thoughts on that?

  • Lee Kelleher 3690 posts 13439 karma points admin core mvp c-trib
    Aug 10, 2017 @ 12:46
    Lee Kelleher
    0

    Are there any JS errors in your browser's dev tools console?

  • Jon R. Humphrey 142 posts 355 karma points
    Aug 10, 2017 @ 14:01
    Jon R. Humphrey
    0

    Hey Lee,

    I swear I posted this reply already but I'll do it again!

    There are no errors showing in the dev tools for the content node:

    enter image description here

    However, when I click on the "+" to try to add a new Nested Content item, there's no dialogue shown, and I wonder if there is something similar to Rasmus' issue that he reported here:

    https://our.umbraco.org/projects/backoffice-extensions/nested-content/nested-content-feedback/86827-updated-umbraco-764-and-nested-content-02-04-with-multiple-doctypes-cannot-add-anything

    But, I'm not using the Grid in this instance, nor DTGE, nor do I receive any dev console errors for NC if I go in and edit the Nested Content Properties via the Document Type itself?

    However, when I do go in and edit the Nested Content property via the Document Type property editor there are no settings pre-filled:

    enter image description here

    Why would the properties lose their references too?

    If I "re-add" the properties that are missing do you think the content would then re-appear in the back office as the references are correct again?

  • Lee Kelleher 3690 posts 13439 karma points admin core mvp c-trib
    Aug 10, 2017 @ 14:04
    Lee Kelleher
    1

    If I "re-add" the properties that are missing do you think the content would then re-appear in the back office as the references are correct again?

    It's definitely worth a try.

    Just checking, you have backups of all this, right? (Just in case bad things happen).

    I'm not sure why the NC's data-type prevalues are all empty... unless it's related to the DocType GUID change too? (as in all the NC data-types need to be re-saved too)

  • Jon R. Humphrey 142 posts 355 karma points
    Aug 10, 2017 @ 14:19
    Jon R. Humphrey
    1

    Lee!!!!

    That was it!!!!

    Going in and copying the "old" DataType properties back into the "new" DataTypes for the Nested Content:

    enter image description here

    reconnected them to their respective content nodes!!!!

    enter image description here

    Thank you thank you thank you!!!

    #h5yr!

  • Lee Kelleher 3690 posts 13439 karma points admin core mvp c-trib
    Aug 10, 2017 @ 14:31
    Lee Kelleher
    1

    Ace! That's good to know.

    Cheers,
    - Lee

Please Sign in or register to post replies

Write your reply to:

Draft