Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Rajmond Burgaj 2 posts 72 karma points
    Jul 14, 2017 @ 22:38
    Rajmond Burgaj
    0

    Umbraco cannot connect with database while installing for first time

    I installed umbraco version 7.6.x but I am trying to connect to my database in

    Microsoft SQL Server 2016 (SP1) (KB3182545) - 13.0.4001.0 (X64) Oct 28 2016 18:17:30 Copyright (c) Microsoft Corporation Express Edition (64-bit) on Windows 10 Home 6.3 (Build 15063: )

    but it does not connect to my database which I have created here. I am using Custom Connection String because selection server name and Integrated Authentication did not work either. While trying Custom Connection String I could connect with another database which was restored and it has 2008 compatibility mode because it is backed up from Sql Server 2008. I tried changing only the db name but does not work for new created one while I can connect with Visual Studio using the same connection string. I tried to set the new created db to 2008 compatibility mode as well but does not work.

    Any idea what is the problem in this case ?

  • Alex Skrypnyk 3895 posts 13826 karma points mvp
    Jul 16, 2017 @ 21:37
    Alex Skrypnyk
    0

    Hi Rajmond

    Can you share connection string with us?

    Thanks,

    Alex

  • Rajmond Burgaj 2 posts 72 karma points
    Jul 17, 2017 @ 09:18
    Rajmond Burgaj
    0

    Here is the connection string.

    Server=localhost\SQLEXPRESS;Database=DbName;Trusted_Connection=True;

  • Alex Skrypnyk 3895 posts 13826 karma points mvp
    Jul 17, 2017 @ 09:57
    Alex Skrypnyk
    0

    Can you try to connect to your database with SQL management studio?

  • Paul Seal from codeshare.co.uk 240 posts 1073 karma points c-trib
    Jul 17, 2017 @ 10:16
    Paul Seal from codeshare.co.uk
    0

    Hi You might not have mixed mode enabled on your SQL Server. Here is how to fix that. https://docs.microsoft.com/en-us/sql/database-engine/configure-windows/change-server-authentication-mode#SSMSProcedure

Please Sign in or register to post replies

Write your reply to:

Draft