Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Marc Love 201 posts 476 karma points
    May 02, 2017 @ 13:43
    Marc Love
    0

    Unable to Install Umbraco 7.6 via Nuget

    Hi,

    I am unable to install Umbraco 7.6 via Nuget. It appears that no one has been able to do this as there are no downloads recorded:

    https://www.nuget.org/packages/UmbracoCms/

    The error I get is:

    Newtonsoft.Json' already has a dependency defined for 'Microsoft.CSharp

    Did a quick search and it appears that the latest version of Newtonsoft.Json is not compatible with ASP.NET 4.5 so I changed my target framework to 4.6

    Still no luck though.

    Anyone else experiencing this and know of a fix?

    Cheers,

    Marc

  • Marc Love 201 posts 476 karma points
    May 02, 2017 @ 14:45
    Marc Love
    0

    If any one else runs into this my fix was to uninstall Nuget Package Manager and then re-install. This seems to have been the issue, target framework wasn't the cause.

  • marc goodson 534 posts 3218 karma points mvp c-trib
    May 02, 2017 @ 19:48
    marc goodson
    0

    Hi Marc

    I noticed the release candidate needed version 3.5 of Nuget (original install of VS2015 will only have version 3.0) - be interested if your reinstall upped the version of Nuget that you had installed?

    or whether you had the latest (eg 4 for VS2017) anyway.. and it just needed turning off and on again ?

    cheers

    Marc

  • Marc Love 201 posts 476 karma points
    May 02, 2017 @ 19:51
    Marc Love
    0

    Hi Marc,

    I had the issue with Visual Studio 2012, uninstalling and re-installing gave me the latest version.

    Cheers,

    Marc

  • Jim Gettrup 4 posts 25 karma points
    May 19, 2017 @ 17:47
    Jim Gettrup
    1

    I had this issue too, and just updating the Nuget Package Manager extension in Visual Studio 2013 was enough to get rid of the error for me.

Please Sign in or register to post replies

Write your reply to:

Draft