Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Bo Jacobsen 102 posts 535 karma points
    Apr 21, 2017 @ 08:00
    Bo Jacobsen
    0

    ERROR Umbraco.Core.Dynamics.ExtensionMethodFinder - Failed to get types.

    Hello.

    using Umbraco version 7.5.4 and uCommerce version 7.5.0.17040 and Newsletter Studio version 2.1.5.

    In one of our webapplications we are getting this error ,from time to time:

    [P10028/D3/T50] ERROR Umbraco.Core.Dynamics.ExtensionMethodFinder - Failed to get types.
        System.Reflection.ReflectionTypeLoadException: Could not load all types from "Spatial4n.Core.NTS, Version=0.3.0.0, Culture=neutral, PublicKeyToken=9f9456e1ca16d45e" due to LoaderExceptions, skipping:
        . System.IO.FileNotFoundException: Could not load file or assembly 'GeoAPI, Version=1.7.4693.18483, Culture=neutral, PublicKeyToken=a1a0da7def465678' or one of its dependencies. The system cannot find the file specified.
        . System.IO.FileNotFoundException: Could not load file or assembly 'GeoAPI, Version=1.7.4693.18483, Culture=neutral, PublicKeyToken=a1a0da7def465678' or one of its dependencies. The system cannot find the file specified.
        . System.IO.FileNotFoundException: Could not load file or assembly 'GeoAPI, Version=1.7.4693.18483, Culture=neutral, PublicKeyToken=a1a0da7def465678' or one of its dependencies. The system cannot find the file specified.
    
           at Umbraco.Core.TypeFinder.GetTypesWithFormattedException(Assembly a)
           at Umbraco.Core.Dynamics.ExtensionMethodFinder.GetTypes(Assembly a)
    

    Maybe its related to this? -> https://our.umbraco.org/forum/using-umbraco-and-getting-started//85279-error-umbracocoreumbracoapplicationbase-unhandled-exception-in-appdomain-terminating

    I have started 2 threads because i think its 2 different problems.

  • Sven Geusens 87 posts 544 karma points
    Apr 21, 2017 @ 15:26
    Sven Geusens
    0

    This seems like you are missing a dll called GeoAPI

    One of your document types seems to be using a property editor that uses https://www.nuget.org/packages/Spatial4n.Core.NTS/ which has a dependency on https://www.nuget.org/packages/NetTopologySuite/ which has a dependency on https://www.nuget.org/packages/GeoAPI/ Which seems to be missing from your dll folder.

  • Bo Jacobsen 102 posts 535 karma points
    Apr 24, 2017 @ 13:56
    Bo Jacobsen
    0

    Hi Sven.

    Thanks again for your reply.

    I will try look into this. And give a feedback :)

Please Sign in or register to post replies

Write your reply to:

Draft