Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Robert Stigsson 47 posts 158 karma points
    Oct 20, 2017 @ 12:28
    Robert Stigsson
    0

    Courier Deploy returns InvalidOperationException

    When choosing Deploy, a Type and then a node (for example: Courier -> Deploy -> Dictionary Items -> dictItem) I get Application Error with InvalidOperationException (more information down below).

    I have just installed it and it's my first time trying to use it, so maybe I've done something wrong in the installation sequence. Have you seen this before?

    Information regarding the system:

    Umbraco CMS: 7.4.3

    Umbraco Courier: 3.1.4

    Application Error
    
    Client found response content type of '', but expected 'text/xml'. The request failed with an empty response.
    
    Error details
    System.InvalidOperationException: Client found response content type of '', but expected 'text/xml'.
    The request failed with an empty response.
    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
    at Umbraco.Courier.RepositoryProviders.WebServiceProvider.RepositoryWebservice.CloseSession(String sessionKey)
    at Umbraco.Courier.RepositoryProviders.CourierWebserviceRepositoryProvider.CloseSession(String sessionKey)
    at Umbraco.Courier.RepositoryProviders.CourierWebserviceRepositoryProvider.Dispose(Boolean disposing)
    at Umbraco.Courier.RepositoryProviders.CourierWebserviceRepositoryProvider.Dispose()
    at Umbraco.Courier.Core.Common.Extensions.GlobalExtensions.DisposeIfDisposable(Object input)
    at Umbraco.Courier.Core.Repository.Dispose(Boolean disposing)
    at Umbraco.Courier.Core.Repository.Dispose()
    at Umbraco.Courier.UI.Dialogs.CommitItem.OnInit(EventArgs e)
    at System.Web.UI.Control.InitRecursive(Control namingContainer)
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    
  • Eric Wilkinson 3 posts 73 karma points
    1 week ago
    Eric Wilkinson
    0

    Hi Robert, I just had this issue and the cause was due to one of the Repositories defined in courier.config to be down (App Service wasn't started yet). Since the deploy feature tries to build a dropdown of the possible repository locations, one of them being inaccessible caused this error. Because the error isn't the expected XML response (in my case it was a UTF-8 html error page being returned rather than the text/xml xml page), it errors saying the content type is incorrect.

    This may be the same issue you are experiencing. Make sure each of your defined repositories are pointed to the correct location, and verify that each location is running (app service spun up and that the connection isn't timing out), and that courier is installed at each defined repository location.

    In my case, I had a development repository which wasn't in use but it was still configured in the courier.config. Removing that repository definition fixed this issue.

Please Sign in or register to post replies

Write your reply to:

Draft