Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Benjamin 6 posts 26 karma points
    Dec 10, 2010 @ 17:15

    Generic Properties Tab - Type drop down empty ?

    Hi all,

    Im relatively new to Umbraco.

    For some reason, the Type drop down under the generic properties tab is empty. If i try to edit existing generic properties in document types I have previously created, these are also empty.

    However, under developer -> data types all are present, and I can add my own without issue.

    This is happening in Chrome, FF and IE so I dont think its a browser based JS issue. 

    Ive tried restarting VS's developemet server and even my box, but still no luck?

    Any help would be greatly appreciated.



  • Benjamin 6 posts 26 karma points
    Dec 10, 2010 @ 18:08

    Edit -- Im posting as a reply as the Edit of my post is failing.

    Ive pointed the 4.5 release source at my database (im using 4.5.2) and in UpdateInterface call in the GenericProprty control code behind, _dataTypeDefinitions is populated, and therefore so is the ddlTypes dropdown. I will dig a little deeper into the genericproperty.js and diff the versions to see if can spot anything.

    Edit 2 --

    Ok, if i change a document types Default Template, under the info tab and then save, the ddlTypes drop down is populated. I can then add new properties to that doc type until i navigate away from that document type and back. After navigation the drop down list is empty.

    This only works when first creating a document type. Trying the same again (changing the Default Template and saving) throws this expection in the right hand side frame:

    Input string was not in a correct format.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: System.FormatException: Input string was not in a correct format.

    Source Error: 

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace: 

    [FormatException: Input string was not in a correct format.]
       System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal) +9594283
       System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info) +119
       System.Int32.Parse(String s) +23
       umbraco.controls.GenericProperties.GenericProperty.get_Type() +80
       umbraco.controls.ContentTypeControlNew.saveProperties(SaveClickEventArgs& e) +1672
       umbraco.controls.ContentTypeControlNew.save_click(Object sender, ImageClickEventArgs e) +326
       System.Web.UI.WebControls.ImageButton.OnClick(ImageClickEventArgs e) +115
       System.Web.UI.WebControls.ImageButton.RaisePostBackEvent(String eventArgument) +120
       System.Web.UI.WebControls.ImageButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +10
       System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +13
       System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +36
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +5563


    Should I post this as a bug? I can just work directly against the database cmsPropertyType table for the time been but that wouldnt be cricket if this was production. Im currently just hacking around at the minute.

    Edit 3 --

    The above method of changing the Default Template and saving works every time, as long as no previous generic properties are assigned to that datatype. The save is failing only when there is at least one. The above error must be coming from the fact its trying to save existing generic properties where the ddlTypes dropdown is empty, and causing the parse exception.

  • Benjamin 6 posts 26 karma points
    Dec 23, 2010 @ 16:36

    /One Week Bump



  • Jan Skovgaard 10761 posts 21147 karma points MVP 4x admin c-trib
    Dec 23, 2010 @ 17:28
    Jan Skovgaard

    Hi Benjamin

    Is it a clean installation of 4.5.2 or have you upgraded from a previous version?

    What permissions have you given the network service and the iusr?

    Are you running ASP.NET 4 and integrated mode in the application pool?


  • Aymeric 1 post 21 karma points
    May 10, 2012 @ 08:31

    I am getting the same error :(

  • Jan Skovgaard 10761 posts 21147 karma points MVP 4x admin c-trib
    May 18, 2012 @ 18:09
    Jan Skovgaard

    Hi Aymeric

    Sorry for the late reply - I'm wondering if you could share some details about your setup? Basically the same information I've asked for in my previous answer to this post.


  • Kåre Petersen 5 posts 26 karma points
    Jun 04, 2012 @ 14:24
    Kåre Petersen

    Hi Jan

    I have the same problem just on a 4.7.2 clean install.


  • James Diacono 16 posts 435 karma points
    Jun 27, 2012 @ 06:17
    James Diacono

    I know this happens when you install Autofac with WebForms integration in an Umbraco project.  When Umbraco loads the document type editor control (GenericProperty.ascx), its public "DataTypeDefinitions" property gets overwritten by Autofac with an empty array.  Hence the select box usually containing the document types turns up empty.

    To get around this problem, use Attributed Injection

  • Kåre Petersen 5 posts 26 karma points
    Jun 28, 2012 @ 22:30
    Kåre Petersen

    Thanx James.. That solved my problem.

Please Sign in or register to post replies

Write your reply to: