Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Gert De Ceuster 27 karma points
    Jul 11, 2011 @ 20:57
    Gert De Ceuster
    0

    After logon to admin page, only progress bar is shown (version 4.7)

    After deploying my unbraco 4.7 site, the side works well, but when I logon to the administration page, only a progress bar is shown. Any help is appriciated. Thanks.

  • Viral Shah57 karma points
    Jul 15, 2011 @ 21:19
    Viral Shah
    0

    I am having exactly same problem and could not yet figure this out. Any help on this is really appreciated.

    Many thanks.

  • Rich Green3510 karma points
    Jul 15, 2011 @ 23:16
    Rich Green
    0

    Possibly a permissions issue, did you double check your file permissions?

    Rich

  • Lee Kelleher10481 karma points admin core mvp c-trib
    Jul 16, 2011 @ 08:39
    Lee Kelleher
    0

    Hi Gert and Viral,

    Check if you've got JavaScript enabled.

    Cheers, Lee.

  • Gert De Ceuster27 karma points
    Jul 16, 2011 @ 11:05
    Gert De Ceuster
    0

    @Lee: Javascript is indeed enabled.

    @Rich: everything underneeth App_Data folder has read/write access. The rest has read access.

    The error I'm getting is that the value of JQuery is null. Could this have something to do with ClientDependency.core.dll?

  • Lee Kelleher10481 karma points admin core mvp c-trib
    Jul 18, 2011 @ 11:21
    Lee Kelleher
    0

    Hi Gert,

    Are there any other errors/warning about JavaScripts not being loaded in?

    I'm thinking it's an issue with the Client Dependency framework ... could you try setting your website to "<compilation debug="true">" in your Web.config? (this will disable Client Dependency - more info here)

    Cheers, Lee.

  • Gert De Ceuster27 karma points
    Jul 18, 2011 @ 13:57
    Gert De Ceuster
    0

    Hi Lee,

    Thanks for the reply. Setting "<compilation debug="true">" helps indeed. But should this be left this way? Is there a solution where I can set the debug parameter back to false?

  • Lee Kelleher10481 karma points admin core mvp c-trib
    Jul 18, 2011 @ 14:49
    Lee Kelleher
    0

    Hi Gert, when you say it helps, do you mean that the back-office is working as expected now?

    If so, then we've found the cause of the problem - the permissions of the ClientDependency directories.  Double-check the file/folder permissions of "\App_Data\TEMP\ClientDependency" for both NETWORK SERVICE user and IIS_IUSRS group. (I've had a problem with not setting IIS_IUSRS before).

    Cheers, Lee.

  • Viral Shah57 karma points
    Jul 18, 2011 @ 17:11
    Viral Shah
    0

    Many thanks Rick and Lee for responding.

    When i made setting "<compilation debug="true">" it worked.

    But as Gert asked -- should this be left this way? Is there a solution where I can set the debug parameter back to false?

    Thanks.

    v

     

  • Gert De Ceuster27 karma points
    Jul 18, 2011 @ 17:23
    Gert De Ceuster
    0

    Hi Lee,

    I can only set the permissions for the NETWORK SERVICE user in the control panel of my hosting.  The IIS_IUSRS group is not showing up in the list. So this means I have to leave my debug set to false?

    I will contact my hosting provider to check if he's got an answer to this.

    Thanks,

    Gert.

  • Lee Kelleher10481 karma points admin core mvp c-trib
    Jul 18, 2011 @ 17:42
    Lee Kelleher
    0

    In answer to the question... "Should you leave your website with <compilation debug="true">"?

    Quick answer is no, you should not. There are good explanations to why: here and here.

    As for which machine user to set with read/write permissions for Client Dependency ... it should be which ever user is associated with the AppPool. If this is on a hosted web-server, best bet is to speak with their tech support team, see if they can help resolve it.

    Good luck!

    Cheers, Lee

     

  • Viral Shah57 karma points
    Jul 18, 2011 @ 20:06
    Viral Shah
    0

    Lee -

    Thanks a lot. It makes sense.

    v

  • Damiaan335 karma points c-trib
    Oct 10, 2011 @ 14:17
    Damiaan
    0

    I had the same problem.  The solution was to add the Handlers Section in the System.WebServer section of the web.config. 

Please Sign in or register to post replies

Write your reply to:

Draft
Our.umbraco.org is the community mothership for Umbraco, the open source asp.net cms. With a friendly forum for all your questions, a comprehensive documentation and a ton of packages from the community. This site is running Umbraco version 7.3.0-beta3