Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Chris Koiak 2615 karma points
    Jan 16, 2011 @ 17:32
    Chris Koiak
    0

    Database connection initialisation failed

    I've just tried to give 4.6.1 and SQL CE a try but can't get it to the installation. I get a Database connection initialisation failed message on step 3.

    I've downloaded Umbraco manually, downloaded and installed SQL CE, copied the UmbracoCE dll and the relevant CE program files dlls.

    I'm running on Windows 7 and .NET 4.

    Anyone else encountered this before?

  • ZiadJ24 karma points
    Jan 21, 2011 @ 11:43
    ZiadJ
    0

    Same here except that I am deploying on a shared hosting.

  • Hendy Racher2791 karma points admin core
    Jan 21, 2011 @ 12:00
    Hendy Racher
    0

    Hi, might be related, but have you checked file permissions (particularly write access to web.config) ?

    Step 3 can fail with "Database connectino initialisation fails" if there are permission issues.

    http://umbraco.codeplex.com/workitem/29896

    HTH,

    Hendy

  • ZiadJ24 karma points
    Jan 21, 2011 @ 14:33
    ZiadJ
    0

    I guess you are right Henry because I got an error saying "Access denied to the file umbraco.config" when I reverted back to the root url. Giving read/write access rights to the App_Data folder fixed it but I was still stuck with the "Database connection initialisation failed." error on the db config page.

    As for the web.config file my hosting control panel at GoDaddy does not allow me to modify permissions for files located in the root folder.

    So the solution I guess is to carry out the installation on my localhost before uploading it to the server.

    Thanks a lot for your help.

  • Brian Kim21 karma points
    Jan 22, 2011 @ 22:00
    Brian Kim
    0

    I have the same "Database connection initialisation failed" error. I'm able to connect to my MS SQL database via management studio with same credentials.

    /install/?installStep=filepermissions page says my permission settings are perfect though...

  • torbad24 karma points
    Jan 24, 2011 @ 14:04
    torbad
    0

    I also have the same problem. I looked at the code, and unless I am missing something I cannot understand how this scenario is supposed to work.

    In p.aspx.cs.installOrUpgrade:

     

                    m_Installer = sqlHelper.Utility.CreateInstaller();
                    if (!m_Installer.CanConnect)
                        throw new Exception("The installer cannot connect to the database.");
    

    The CanConnect property is false as long as CurrentVersion equals the 'Unavailable' version. By looking at the 'DetermineCurrentVersion' code in DefaultInstallerUtility, it looks to me that for a clean db with no umbraco tables, the currentversion will indeed be 'Unavailable', hence the problem to "connect".

            public virtual bool CanConnect
            {
                get { return CurrentVersion != DatabaseVersion.Unavailable; }
            }
    
  • Oluwole Kolawole52 karma points
    Mar 08, 2011 @ 21:11
    Oluwole Kolawole
    0

    Hi,

    I can confirm that Umbraco needs to be able to write to the web.config file (I guess to save the connection string there) for the database initialisation to proceed.

    I was installing to a MySQL database on GoDaddy and had to set permissions to read/write for it to work (in my case, I set everything to read/write, but I reckon it's only the web.config file and a few other folders that need to be done).

    Sine you can't actually set permissons on files with the GoDaddy File Manager, you need to set permissions to the folder containing the web.config file. In my case I was installing to a subfolder so I could set permissions on that sub-folder. If you're installing to the main root however, I wouldn't know how to set write permissions here. Perhaps a call to GoDaddy would help :-|.

    Regards,
    Wole.

  • Brian Almeter22 karma points
    Mar 16, 2011 @ 12:07
    Brian Almeter
    1

    I corrected my installation by editing the connection string in the web.config and then uploaded it to my hosting server. Installation succeeded.

    Brian

  • Jacques S.25 karma points
    Mar 30, 2011 @ 12:29
    Jacques S.
    0

    hi,

    in case of Windows 7, IIS7.5 this issue will arise if you don't have the proper authentication set for the "ASP.Net impersonation". I had this set to "Disabled" by default. If you change it to "Enabled" and relaunch the process it should work. (This also applies to the file check issue)

    To change this setting in Windows 7, go into IIS manager, select the website you're working on and click the "Authentication" in the "IIS" section. From the list set "ASP.Net impersonation" to "Enabled".

    hope this helps,

    Jacques.

  • JP Hellemons21 karma points
    Jan 17, 2012 @ 11:49
    JP Hellemons
    0

    Hi, I have exactly the same thing:

    everything looks fine:

    2. Simple file-based database:

    Nothing to configure:SQL CE 4 does not require any configuration, simply click the "install" button to continue.

    but when I hit, next: Database connection initialisation failed.

    My situation: Windows 2003, asp.net 4

    I installed Umbraco today with the web platform installer and chose to use SQL CE

     

    Edit: I added the umbraco rss feed to the web platform installer and tried to overwrite everything with umbraco 5.0 rc2 and now I get an error overwriting umbraco/bin\x86\sqlceer40EN.dll because it is being used by another process but I do not know what process so I cannot kill it.

     

    Edit 2: I have removed everything from the folder (by stopping the application pool) and re-installed umbraco (choose 4.7.1.1, because 5.0 rc2 didn't work) from the web pi feed. And now it all seems to work! even the business starter kit works!

  • JDS23 karma points
    Dec 11, 2012 @ 22:02
    JDS
    0

    Hello,

    I have the same problem with version 4.8 configured on Shared Hosting.

    Doen anyone know what to do?

Please Sign in or register to post replies

Write your reply to:

Draft
Our.umbraco.org is the community mothership for Umbraco, the open source asp.net cms. With a friendly forum for all your questions, a comprehensive documentation and a ton of packages from the community.