Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Jose 5 posts 25 karma points
    Jul 07, 2010 @ 01:05
    Jose
    0

    Installing Umbraco on shared hosting or Medium trust

    Hello,

    I would like to know as many other people what considerations are necesary to deploy a website in a shared or medium trust hosting using Umbraco 4.5 in the features shows medium trust support, but there is any documentation on how to do it, maybe someone of the great umbraco stuff could give us some help with this, at least what is necesary to do to make Umbraco work.

    I found a hacked umbraco 4.0.3 version for medium trust, but with the new version that supports medium trust I think could be better to use the new version.

    Thank you.

  • Adriano Fabri681 karma points
    Jul 17, 2010 @ 02:48
    Adriano Fabri
    0

    Hi,

    I'm also interested to use umbraco 4.5 in a medium trust hosting but I didn't found any documentation that explain how to configure it for medium trust.

    Thank you

  • Jose25 karma points
    Jul 17, 2010 @ 06:31
    Jose
    0

    Hi,

    I have installed umbraco on a shared server succesfully after weeks of trying and trying, and constant comunication with my web hosting company well here is how I do it.

    1. Contacted to web host and ask for Full Control permissions for ASP application to the files and folders of umbraco http://umbraco.org/documentation/books/important-files-and-folder-structure/permissions.

    2. At first I modified the web.config this lines <add key="umbracoUseMediumTrust" value="true" />, <trust level="Medium" originUrl=".*" />  but later it was not necesary.
    3. The installation was fine, but some problems occurs when I tried to create new content (permission errors even when the permissions were setup) .
    4. After searching in the forums I found to change the <!-- <trust level="Medium" originUrl=".*" /> --> for <trust level="Full" /> this will work if you have full control permission on the files of umbraco especially on App_Data, App_Browsers

    I hope this will help you.

     Regards,

    José

  • Sebastiaan Janssen9319 karma points admin mvp hq
    Jul 17, 2010 @ 09:02
    Sebastiaan Janssen
    0

    Umbraco 4.5 should be able to support medium trust out of the box, earlier version just don't. And yes, you have to make I think two changes in the web.config:

    <add key="umbracoUseMediumTrust" value="false" />

    Should become "true".

    <!-- <trust level="Medium" originUrl=".*" />-->

    Should be uncommented.

  • Thiago Passos25 karma points
    Sep 05, 2010 @ 10:32
    Thiago Passos
    0

    Hi,

    Are there more information about how to install Umbraco 4.5.* with Medium Trust?

    I recently got a cloud site on Rackspace. They don't allow applications to run using Full Trust environment. They even have a web page explaining how their Medium Trust works (http://cloudsites.rackspacecloud.com/index.php/Overview_of_modified_Medium_Trust). On this page they say that Umbraco doesn't work there.

    I believe that this information was put there before the version 4.5. Can someone help me to know if it's possible to install Umbraco there?

    I have tried to change the Web.Config with the information provided by Sebastiaan on his post and I still can't install Umbraco. The error I'm getting is:

    Server Error in '/' Application.
    The application attempted to perform an operation not allowed by the security policy. &nbsp;To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

    Rackspace seems to have a good cloud service for a affordable price. It'd a shame if we can't install Umbraco on it, though.

    Any help will be welcome! Cheers!

  • Sebastiaan Janssen9319 karma points admin mvp hq
    Sep 05, 2010 @ 10:37
    Sebastiaan Janssen
    0

    A modified version of 4.0.3. Seemed to work a few months ago and these changes have been rolled into the 4.5.x branche. Have a look at this topic for a detailed explanation of how to get it to work.

  • Thiago Passos25 karma points
    Sep 05, 2010 @ 11:43
    Thiago Passos
    0

    Hi Sebastiaan, thanks for the quick reply!

    The Benjamin's website is not working and I couldn't get his modified version. As I was reading in some topics, I believe that Rackspace has changed its settings since 5 months ago when the topic you showed me has raised.

    When you say that the changes have been rolled to the 4.5 version you meant that I could use the 4.5.2 and I wouldn't need to use the Benjamin's one. Is that right?

    I'm still getting the error 'The application attemped to perform an operation nor allowed....' Not good.

    Thanks!

  • Sebastiaan Janssen9319 karma points admin mvp hq
    Sep 05, 2010 @ 11:46
    Sebastiaan Janssen
    0

    Exactly, you won't need the modified version any more. Umbraco 4.5 runs in medium trust. 

    As I'm reading it, the Rackspace settings did change 5 months ago and this is how it was solved.. I don't know if they've changed their settings again after that..

    Did you follow all of the instructions? Maybe you should try asking in the other thread as I don't have any experience with Rackspace..

  • Ricky Beard116 karma points
    Sep 06, 2010 @ 01:29
    Ricky Beard
    0

    I just moved several sites to medium trust on Rackspace Cloud Sites and I documented the process.

    http://www.rickybeard.com/blog/2010/9/2/running-umbraco-on-rackspace-cloud-sites

  • Adriano Fabri681 karma points
    Sep 06, 2010 @ 11:28
    Adriano Fabri
    0

    There are two version you can use in those providers who use only Medium Trust configuration policy:

    Umbraco v4.0.3 and Umbraco v4.5

    I tried all two versions and function properly.

     

  • Thiago Passos25 karma points
    Sep 08, 2010 @ 01:51
    Thiago Passos
    1

    Hi Guys! Problem solved installing Umbraco on Rackspace Cloud sites using Medium Trust!

    Only Medium Trust Application are allowed over there and the Umbraco 5.4.2 does install properly. The necessary changes on the Web.Config file are:

    1) UmbracoUseMediumTrust set to 'true'

    <add key="umbracoUseMediumTrust" value="true" />

    2) Do not uncomment the line below. Rackspace does not allow application level overwrites and it will cause an exception.

    <!-- <trust level="Medium" originUrl=".*" />-->

    3) Add impersonate to the <system.web> section in order to have write permission. Check this link for more information on that: http://cloudsites.rackspacecloud.com/index.php/How_do_I_add_impersonation_to_my_ASP.NET_site%3F

    <identity impersonate="true" userName="dfw\YOUR_FTP_USERNAME" password="YOUR_FTP_PASSWORD" /> 

    That's it. The install process should run smoothly.

    The issue I was having was with write permissions using impersonate and a client FTP account. It wasn't creating folders (necessary when uploading media and others). It did work when using my principal FTP account but using a client FTP account folders were not allowed to be created. The Rackspace's Windows team has solved this issue.

    Rackspace has a web page where they say that Umbraco does not work on their server. This is out of date! I think someone from the Umbraco Admin team should contact them to update it.

    http://cloudsites.rackspacecloud.com/index.php/Overview_of_modified_Medium_Trust 

    Thanks to everyone for helping me!

  • Ricky Beard116 karma points
    Sep 08, 2010 @ 18:29
    Ricky Beard
    0

    You just rewrote everything I documented in the article I referenced two posts above yours. Some solution love would be nice :)

  • louie_nz29 karma points
    Dec 27, 2010 @ 14:20
    louie_nz
    0

    Hi, Sebastiaan & Adriano, how did you make

     <trust level="Medium" originUrl=".*" />

    work in your web.config file???

    My site is running umbraco 4.5.2 at .net 3.5 in localhost. However, I can never make Medium trust work for my site. The imageManipulation error always occurs. I don't think it's related to .net 3.5. How did you guys make it work? I am trying to deploy it to GoDaddy, but lots of people give up this as Medium trust screw up umbraco site.

    Cheers

    Louie

     

     

     

  • Luca Anchini29 karma points
    Dec 27, 2010 @ 17:04
    Luca Anchini
    0

    Hi,

    I've the same problem with register.it ISP and all the solution about are not solve my problem....

     

    Any new idea?

  • louie_nz29 karma points
    Dec 31, 2010 @ 05:56
    louie_nz
    0

    Hi Luca, I don't know about register.it ISP, but my case is working in Godaddy now by using umbraco 4.5.2 in .net 3.5. Not sure if it helps. Check the link:

    http://our.umbraco.org/forum/getting-started/installing-umbraco/13880-Installing-Umbraco-on-GoDaddy?p=2

Please Sign in or register to post replies

Write your reply to:

Draft
Our.umbraco.org is the community mothership for Umbraco, the open source asp.net cms. With a friendly forum for all your questions, a comprehensive documentation and a ton of packages from the community. This site is running Umbraco version 7.3.0-RC