Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • William L 3 posts 24 karma points
    Jun 25, 2010 @ 06:27
    William L
    0

    Umbraco 4.5 - Dontnetpanel Server Error system.web.extensions

    I have 4.5 running localhost fine. When I try to install to my host Dontnetpanel gives me an error:

    Line number: 154
    Error: The configuration section 'system.web.extensions' cannot be read because it is missing a section declaration

    If i remove from web.config

    <!-- ASPNETAJAX -->
      <system.web.extensions>
        <scripting>
          <scriptResourceHandler enableCompression="true" enableCaching="true" />
        </scripting>
      </system.web.extensions>

    I can get to the umbraco install screen.

     

     

  • Rich Green3560 karma points
    Jun 25, 2010 @ 08:37
    Rich Green
    0

    Looks like your site on your host is not running under .NET 4.

    You need to either change it so it is, or I believe there's a version of Umbraco 4.5 that runs under .NET 3.5 (I'm not 100% on this).

    Best of luck

    Rich

  • William L24 karma points
    Jun 25, 2010 @ 18:21
    William L
    1

    Thanks Rich,

    For anyone else having this problem with Softsys this is the reply I got from support.

    "It apears that this config section would already be declared on the server level or may be something is messing up. I've commented it out for now and you can go ahead with your installation."

    It seems to be working with the section commented but I don't know if there will be any side effects.

     

  • Ulrich Wagner Gade Ebsen125 karma points
    Jun 25, 2010 @ 18:39
    Ulrich Wagner Gade Ebsen
    0

    Hi,

    DotNetPanel has become opensource under the name WebSitePanel (www.websitepanel.net) - tell your host to upgrade as there won't be any further updates to DotNetpanel.

    /ulrich

  • Thomas Kjær Nielsen88 karma points
    Jun 25, 2010 @ 20:31
    Thomas Kjær Nielsen
    0

    Hi

    I had the same problem, and it also got fixed by commenting the AJAX stuff out.

    But now I get error about the .NET Framework. Gonna read a bit about that part.

    /Thomas

  • Dan Thayer24 karma points
    Jun 25, 2010 @ 20:51
    Dan Thayer
    0

    Umbraco 4.1 RC only ran under .NET Framework 4.0 but Umbraco 4.5 was supposed to work under .NET Framework 3.5 OR 4.0.  I tried installing today under .NET 3.5 and ran into the same error.  Switching to .NET 4.0 fixes that error.

    Dan

  • Anders Dahl Tollestrup52 karma points
    Jun 26, 2010 @ 11:09
    Anders Dahl Tollestrup
    0

    Hi

    As posted, the DotNetPanel doesn't support .NET 4.0 and my hoster SeekDotNet has to enable .NET 4.0 framework manually for each site.

    /Anders

  • Paul Blair730 karma points
    Jul 19, 2010 @ 12:39
    Paul Blair
    0

    I was having the same issue with SoftSys and Williams post sorted out the issue for me.

  • Ulrich Wagner Gade Ebsen125 karma points
    Jul 19, 2010 @ 12:47
    Ulrich Wagner Gade Ebsen
    0

    Anders, DotNetPanel (now WebSitePanel) indeed supports .NET 4.0!

    If your hosting provider has trouble with it I can provide hosting with full support for .NET 4.0/umbraco 4.5 and with WebSitePanel (former DotNetPanel) and its very fair priced... ;)

    Ulrich Wagner Gade Ebsen
    ECORE

     

  • Simon Justesen203 karma points
    Jul 19, 2010 @ 13:01
    Simon Justesen
    0

    If you want, you can find the umbraco 4.5 for .net 3.5 here: http://nightly.umbraco.org/ (may not be production stable, haven't experienced problems though)

  • Kevon K. Hayes280 karma points
    Jul 30, 2010 @ 17:09
    Kevon K. Hayes
    0

    I was able to solve my issue by enabling Allowing .NET 4.0.3 under ISAPI Restrictions:

  • sun391 karma points
    Jan 26, 2011 @ 09:27
    sun
    1

    following is to solve this problem. it's chinese. I post it here just want to let someone know where to do this.

    :
    iis7
    xx\xx\xxx\web.config
    133
    :"system.web.extensions",


    Line number: 154
    Error: The configuration section 'system.web.extensions' cannot be read because it is missing a section declaratio
    http://our.umbraco.org/forum/getting-started/installing-umbraco/10095-Umbraco-45-Dontnetpanel-Server-Error-systemwebextensions

    IIS7
    1..net 4.0
    2..net4.0(>>>>)
    3.“”Set the Manage Pipeline mode from Integrated to Classic
    Run website on IIS7 (Vista) in classic mode
    IIS



    http://forums.asp.net/p/1547286/3784899.aspx
     

    This is because config section hasn't declared. in 4.0 webconfig you have to add it manually.

    <configSections>

        <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
          <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
            <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
            <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
              <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="Everywhere"/>
              <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
              <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
              <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
            </sectionGroup>
          </sectionGroup>
        </sectionGroup>

    </configSections>

    --------
    iis7

    404

    http 404.2 -not found
    web"isapiCGI"
    IsapiModule
    ExecuteReauestHandler
    :PageHandlerFactory-ISAPI-4.0_32bit
    :0x800704ec


    IIS  “ISAPICGI”.net4,

    “”“”“”

Please Sign in or register to post replies

Write your reply to:

Draft
Our.umbraco.org is the community mothership for Umbraco, the open source asp.net cms. With a friendly forum for all your questions, a comprehensive documentation and a ton of packages from the community. This site is running Umbraco version 7.3.0-RC