Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Masood Afzal 176 posts 520 karma points
    Feb 11, 2010 @ 16:27
    Masood Afzal

    Unable to publish/republish 8000 nodes - URGENT

    Umbraco 4.0.3 / ASP.NET 3.5 / Windows Server 2003/ MS SQL Server 2005

    I have created approx 8000 published nodes and trying to update cahce but it fails after running some time. Looks like some of nodes have been added to umbraco cache file but not all of 8000.

    I have tried 'Republish entire site' and 'Publish' options.

    Any help would be highly appreciated




  • Seth Niemuth 275 posts 396 karma points
    Feb 11, 2010 @ 16:49
    Seth Niemuth

    Make a copy of the umbraco.config file (in your data folder) and delete it or just rename it. Then do the 'Republish Entire Site', it will recreate the 'cache' or XML file of all the nodes. Sometimes the file can just go weird.

  • Masood Afzal 176 posts 520 karma points
    Feb 11, 2010 @ 16:53
    Masood Afzal

    Thanks Seth,

    I have removed it and tried 'republishing entire site' many times, but it didn't work. When i pulish the folder, it displays number of published documents and at 400+, restarts counting from 1 again


  • Jeroen Breuer 4376 posts 9994 karma points admin mvp c-trib
    Feb 11, 2010 @ 16:56
    Jeroen Breuer

    The display number doesn´t always work. If you look at the size of you umbraco.config file does it still get bigger if the count restart from 1 again? If it is the nodes are still being published and you should probably just wait.

  • dandrayne 1138 posts 2261 karma points
    Feb 11, 2010 @ 17:10

    Publishing problems are often caused by lucene indexing, so perhaps disabling that will help

    Also, in your web.config you could try to increase the

    executionTimeout = "number" 


    Inside the httpRuntime tag.


  • Christian W. Larsen 27 posts 48 karma points
    Feb 11, 2010 @ 17:36
    Christian W. Larsen

    Did you check the umbracoLog-table? There might be a clue. 

    Could be corrupt data in some node/document.

  • Masood Afzal 176 posts 520 karma points
    Feb 11, 2010 @ 17:49
    Masood Afzal
    Error updating item: umbraco.DataLayer.SqlHelperException: Umbraco Exception (DataLayer): SQL helper exception in ExecuteNonQuery ---> System.Data.SqlClient.SqlException: Arithmetic overflow error converting expression to data type datetime.
    The statement has been terminated.
       at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)
       at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
       at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
       at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
       at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)
       at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async)
       at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result)
       at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe)
       at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
       at Microsoft.ApplicationBlocks.Data.SqlHelper.ExecuteNonQuery(SqlConnection connection, CommandType commandType, String commandText, SqlParameter[] commandParameters)
       at Microsoft.ApplicationBlocks.Data.SqlHelper.ExecuteNonQuery(String connectionString, CommandType commandType, String commandText, SqlParameter[] commandParameters)
       at umbraco.DataLayer.SqlHelpers.SqlServer.SqlServerHelper.ExecuteNonQuery(String commandText, SqlParameter[] parameters)
       at umbraco.DataLayer.SqlHelper`1.ExecuteNonQuery(String commandText, IParameter[] parameters)
       --- End of inner exception stack trace ---
       at umbraco.DataLayer.SqlHelper`1.ExecuteNonQuery(String commandText, IParameter[] parameters)
       at umbraco.cms.businesslogic.datatype.DefaultData.set_Value(Object value)
  • Masood Afzal 176 posts 520 karma points
    Feb 11, 2010 @ 17:55
    Masood Afzal

    Looks like breaking at converting data to DateTime

  • Morten Bock 1800 posts 1884 karma points admin c-trib
    Feb 11, 2010 @ 18:52
    Morten Bock

    Umbraco 4.0.3 has had a problem with datepicker datatypes, caused by a bug in the datalayer code.

    There was a fix released that might help you out. 

    Some relevant links in this post (also link to a build containing the fix):'t-work

  • Morten Christensen 586 posts 2640 karma points admin hq
    Feb 11, 2010 @ 18:57
    Morten Christensen

    Does this problem also occur if you only publish a few nodes or maybe just the second lowest level - or only when doing a complete (re)publish?

    I'm wondering if the exception can be traced to a single node, document type or data type.

    - Morten

  • Masood Afzal 176 posts 520 karma points
    Feb 11, 2010 @ 19:11
    Masood Afzal

    If i publish even a single page, publishing is ok but in audit trial, following message is recorded

    Error removing node from umbraco index: 
    'System.IO.FileNotFoundException: Could not find file 'C:\PROJECTS\XYZ\trunk\wwwroot\data\_systemUmbracoIndexDontDelete\_ze.fnm'. File name: 'C:\PROJECTS\XYZ\trunk\wwwroot\data\_systemUmbracoIndexDontDelete\_ze.fnm' at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy) at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share) at Lucene.Net.Store.FSIndexInput.Descriptor..ctor(FSIndexInput enclosingInstance, FileInfo file, FileAccess mode) at Lucene.Net.Store.FSIndexInput..ctor(FileInfo path) at Lucene.Net.Store.FSDirectory.OpenInput(String name) at Lucene.Net.Index.FieldInfos..ctor(Directory d, String name) at Lucene.Net.Index.SegmentReader.Initialize(SegmentInfo si) at Lucene.Net.Index.SegmentReader.Get(Directory dir, SegmentInfo si, SegmentInfos sis, Boolean closeDir, Boolean ownDir) at Lucene.Net.Index.IndexReader.AnonymousClassWith.DoBody() at Lucene.Net.Store.Lock.With.Run() at Lucene.Net.Index.IndexReader.Open(Directory directory, Boolean closeDirectory) at Lucene.Net.Index.IndexReader.Open(String path) at umbraco.cms.businesslogic.index.Indexer.RemoveNode(Int32 Id)'
  • Chris Koiak 700 posts 2615 karma points
    Feb 11, 2010 @ 19:26
    Chris Koiak

    Hi Masood,

    Sounds like a lucene issue, or maybe a permissions error?

    Have you tried the solutions on


    If I were you I'd back up the site, check the permissions, remove everything in the /data directory and republish everything.



  • Sebastiaan Janssen 3890 posts 9825 karma points admin mvp hq
    Feb 11, 2010 @ 19:31
    Sebastiaan Janssen

    Have you tried right-clicking "Content" at the top and choosing "Republish entire site" (just to get the site back up)?

    When the site is running again, you can concentrate on writing an AfterPublish eventhandler that will log whether a node was published, that way, you can more easily find the node at fault.

  • Masood Afzal 176 posts 520 karma points
    Feb 13, 2010 @ 00:30
    Masood Afzal

    Thanks evey one, this issue has been solved now.



  • Douglas Robar 3496 posts 4181 karma points admin mvp c-trib
    Feb 14, 2010 @ 16:41
    Douglas Robar

    Fantastic new, Masood!

    Can you explain how you solved it for the next person who has a similar issue?


  • Masood Afzal 176 posts 520 karma points
    Feb 14, 2010 @ 17:08
    Masood Afzal

    hi Doug,

    I have tried solutions as noted by Chris , Sebastiaan and others but not worked for me. I have unpublished & republish entire site programatically, and all looks ok but i am still concerned about speed, and umbraco.config file is also over 40MB.




Please Sign in or register to post replies

Write your reply to:

Draft is the community mothership for Umbraco, the open source cms. With a friendly forum for all your questions, a comprehensive documentation and a ton of packages from the community. This site is running Umbraco version 7.3.1