x First time here? Check out the FAQ
Join us a the Umbraco event of the year - get your Codegarden 14 early bird ticket today
  • Avatar7posts27karma

    After logon to admin page, only progress bar is shown (version 4.7)

    Gert De Ceuster started this topic July 11, 2011 @ 08:57

    After deploying my unbraco 4.7 site, the side works well, but when I logon to the administration page, only a progress bar is shown. Any help is appriciated. Thanks.


  • Avatar24posts53karma
    Comment with ID: 83638
    Viral Shah posted this reply July 15, 2011 @ 09:19

    I am having exactly same problem and could not yet figure this out. Any help on this is really appreciated.

    Many thanks.


  • Avatar2243posts3096karma
    Comment with ID: 83644
    Rich Green posted this reply July 15, 2011 @ 11:16

    Possibly a permissions issue, did you double check your file permissions?

    Rich


  • Avatar3036posts8600karma
    adminComment with ID: 83651
    Lee Kelleher posted this reply July 16, 2011 @ 08:39

    Hi Gert and Viral,

    Check if you've got JavaScript enabled.

    Cheers, Lee.


  • Gert De Ceuster posted this reply July 16, 2011 @ 11:05

    @Lee: Javascript is indeed enabled.

    @Rich: everything underneeth App_Data folder has read/write access. The rest has read access.

    The error I'm getting is that the value of JQuery is null. Could this have something to do with ClientDependency.core.dll?


  • Avatar3036posts8600karma
    adminComment with ID: 83702
    Lee Kelleher posted this reply July 18, 2011 @ 11:21

    Hi Gert,

    Are there any other errors/warning about JavaScripts not being loaded in?

    I'm thinking it's an issue with the Client Dependency framework ... could you try setting your website to "<compilation debug="true">" in your Web.config? (this will disable Client Dependency - more info here)

    Cheers, Lee.


  • Gert De Ceuster posted this reply July 18, 2011 @ 01:57

    Hi Lee,

    Thanks for the reply. Setting "<compilation debug="true">" helps indeed. But should this be left this way? Is there a solution where I can set the debug parameter back to false?


  • Avatar3036posts8600karma
    adminComment with ID: 83777
    Lee Kelleher posted this reply July 18, 2011 @ 02:49

    Hi Gert, when you say it helps, do you mean that the back-office is working as expected now?

    If so, then we've found the cause of the problem - the permissions of the ClientDependency directories.  Double-check the file/folder permissions of "\App_Data\TEMP\ClientDependency" for both NETWORK SERVICE user and IIS_IUSRS group. (I've had a problem with not setting IIS_IUSRS before).

    Cheers, Lee.


  • Avatar24posts53karma
    Comment with ID: 83813
    Viral Shah posted this reply July 18, 2011 @ 05:11

    Many thanks Rick and Lee for responding.

    When i made setting "<compilation debug="true">" it worked.

    But as Gert asked -- should this be left this way? Is there a solution where I can set the debug parameter back to false?

    Thanks.

    v

     


  • Gert De Ceuster posted this reply July 18, 2011 @ 05:23

    Hi Lee,

    I can only set the permissions for the NETWORK SERVICE user in the control panel of my hosting.  The IIS_IUSRS group is not showing up in the list. So this means I have to leave my debug set to false?

    I will contact my hosting provider to check if he's got an answer to this.

    Thanks,

    Gert.


  • Avatar3036posts8600karma
    adminComment with ID: 83817
    Lee Kelleher posted this reply July 18, 2011 @ 05:42

    In answer to the question... "Should you leave your website with <compilation debug="true">"?

    Quick answer is no, you should not. There are good explanations to why: here and here.

    As for which machine user to set with read/write permissions for Client Dependency ... it should be which ever user is associated with the AppPool. If this is on a hosted web-server, best bet is to speak with their tech support team, see if they can help resolve it.

    Good luck!

    Cheers, Lee

     


Pages:

Please login or Sign up To post replies