x First time here? Check out the FAQ

Come work for Umbraco - The Umbraco HQ are hiring Project managers, .NET developers and DevOps people!

  • Avatar87posts172karma

    Backend: URLs in CSS

    Matthias started this topic July 19, 2010 @ 10:11

    Hi,

    i moved our website from a load balanced environment (1) to a single server (2).
    In (1) i reached the Umbraco backend via www1.ourdomain.com/umbraco, in (2) i use www.ourdomain.com/umbraco. 
    Problem: some of the (generated) paths in the CSS file still point to http://www1.ourdomain.com which leads to missing images in the backend. How can i get rid of the old domain? Is there a misconfiguration or some cache to be emptied?

    Thanks
    Matthias


  • Ismail Mayat posted this reply July 19, 2010 @ 11:30

    Matthias,

    not sure what you mean by generated paths in the css, though they can only be added manually by tying them into css.  If someone has entered the images with fully qualified path eg  http://www1.ourdomain.com/images/myimage.jpg then just take out the domain so url becomes /images/myimage.jpg ?

    Regards

    Ismail


  • Lee Kelleher posted this reply July 19, 2010 @ 11:42

    Hi Matthias, which version of Umbraco are you using?  If it is v4.5, could it be a ClientDependency caching issue?

    If its v4.0.x - as Ismail says, try manually removing the domains?

    Cheers, Lee.


  • Avatar87posts172karma
    Comment with ID: 39711
    Matthias posted this reply July 19, 2010 @ 11:57

    Hi,

    sorry for the missing details.

    I use v4.5. When i open the CSS file on the server, e.g. \umbraco\css\umbracoGui.css, the path looks like this: background-image: url('../images/tray/traySprites.png'); When i check the CSS in the browser (via developer tools) the path is converted to: background-image: url('http://www1.ourdomain.com/images/tray/traySprites.png');
    There are no hardcoded paths/links.

    Thanks
    Matthias

     


  • Lee Kelleher posted this reply July 19, 2010 @ 12:02

    Try deleting the files from the "\App_Data\ClientDependency" directory.  Something might be cached in there?

    Have you tried different web-browsers and machines? Just to rule out that it's not a caching issue.

    Cheers, Lee.


  • Avatar87posts172karma
    Comment with ID: 39714
    Matthias posted this reply July 19, 2010 @ 12:12

    I deleted all files from the "\App_Data\ClientDependency" directory - without success. Yes, i tried different browsers.

    Matthias


  • Lee Kelleher posted this reply July 19, 2010 @ 12:21

    How frustrating! :-|

    Not sure what else to suggest.  If there is no reference to the "www1" subdomain, then it shouldn't be using it - which means that it must be being referenced somewhere, right?

    When you view the CSS directly in your browser, does it have the old domain paths? http://www.ourdomain.com/umbraco/css/umbracoGui.css

    It's not IIS doing some redirect on static files? (That's a long shot!)

    - Lee


  • Avatar87posts172karma
    Comment with ID: 39724
    Matthias posted this reply July 19, 2010 @ 01:23

    Hi Lee, didn't find a hint or solution, yet.

    Just re-registered the www1 hostheader in iis to be able to work again.

    Matthias


  • Fourfinger posted this reply March 20, 2012 @ 10:01

    Hello guys,

    Sorry to post in an old topic but I'm having a similar problem.

    I've copied my Umbraco from my http://localhost:3388 to http://domain/InstallationName/ and the CSS fails.

    I have the developer toolbar (Firefox) installed, and when I check my CSS files from there (even after CTRL+F5 and deleting ClientDependency folders) they contain weird html code. Small sample below.

    Anyone got a clue as how come this is happening? Im guessing it has something to do with the fact the installation is now at "/somefolder" instead of the root domain?

     edit: Stupid me! Now I see the problem? Umbraco thinks all the CSS is located at domain.org/css but in fact it's domain.org/SomeFolder/css.

     

    Can't I fix this?

    http://begijnhof.no-ip.org/css/friendly-ghost_dark.css

    The page cannot be found
    
    

Please login or Sign up To post replies